====== MP STUDIO 2 Phase 9 · メニューと設定 ====== MP STUDIO 2のメニュー項目とオプション設定、言語・テーマ、印刷、Modbus RTU マスター、自動保存、問題の報告とヘルプについて説明します。メニュー項目の右側にはショートカットキーも表示されます。 ===== プロジェクトメニュー ===== {{ :ja-jp_products:mp_studio:menu-project.png?240 |図1. プロジェクトメニュー }} ^ 項目 ^ ショートカット ^ 動作 ^ | 新規プロジェクト | ''Ctrl+N'' | 空のラダーで新しいプロジェクトを作成します。機種の設定は引き継がれます。 | | プロジェクトを開く | ''Ctrl+O'' | ''.mpx''・''.mpl''プロジェクトを開きます。 | | プロジェクトを保存 | ''Ctrl+S'' | 現在のプロジェクトを''.mpx''形式で保存します。''.mpl''を開いた場合は同じ名前の''.mpx''ファイルとして保存され、元の''.mpl''はそのまま残ります。 | | 名前を付けて保存 | ''Ctrl+Alt+S'' | 別の名前または別の場所に保存します。 | | 印刷・ページ設定・印刷プレビュー | ''Ctrl+P'' | Windowsの印刷ダイアログを開きます。用紙とプレビューはそのダイアログで選択します。 | | サンプルを開く | — | 同梱のサンプルプログラムを開きます。 | | 自動保存の復元… | — | 残っている自動保存データを開きます。[[#自動保存と復元|自動保存と復元]]を参照してください。 | | 最近使ったファイル | — | 最近開いたプロジェクト5件がメニューの下部に表示されます。マウスポインターを合わせると、フルパスが表示されます。 | 保存していない変更があるときに**新規プロジェクト**・**プロジェクトを開く**・**サンプルを開く**を実行するか、ウィンドウを閉じると、保存するかどうかを確認します。保存しようとするファイルが別のプログラムで変更されていた場合は、上書きするかどうかを先に確認します。 ===== 編集・検索メニュー ===== {{ :ja-jp_products:mp_studio:menu-edit.png?300 |図2. 編集メニュー }} {{ :ja-jp_products:mp_studio:menu-search.png?390 |図3. 検索メニュー }} 編集メニューと検索メニューの項目は、[[:ja-jp_products:mp_studio:ladder_editing|Phase 3 · ラダー編集]]と[[:ja-jp_products:mp_studio:download#プログラムのチェック|Phase 6 · プログラムチェック]]で説明します。すべてのショートカットは[[:ja-jp_products:mp_studio:quick_reference|クイックリファレンス]]にあります。 ===== 表示メニュー ===== ^ 項目 ^ ショートカット ^ 動作 ^ | シンボルを表示・コメントを表示 | — | セルにシンボル名とコメントを併せて表示します。 | | ブックマーク一覧 | — | ファンクションパネルの下にあるブックマーク一覧の表示・非表示を切り替えます。 | | 記号レール・ファンクション・インスペクター・ウォッチ・コマンドバー・ステータス表示 | ''Alt+1''~''Alt+7'' | パネルの表示・非表示を切り替えます。 | | すべてのパネルを隠す | ''Alt+0'' | すべてのパネルを隠します。 | | 拡大・縮小・画面の幅に合わせる | ''Ctrl+=''・''Ctrl+-'' | ラダーの表示サイズを変更します。''Ctrl+0''で100%になります。 | | クイック実行 | ''Ctrl+K'' | メニュー項目を名前で探して実行します。 | ===== 実行メニュー ===== {{ :ja-jp_products:mp_studio:menu-run.png?440 |図4. 実行メニュー }} ^ 項目 ^ ショートカット ^ 説明ページ ^ | 接続 | — | [[:ja-jp_products:mp_studio:download#イーサネット接続|Phase 6]] | | ダウンロード | ''Ctrl+T'' | [[:ja-jp_products:mp_studio:download#ダウンロード|Phase 6]] | | ファームウェアのダウンロード・ファームウェアのバージョン | — | [[:ja-jp_products:mp_studio:download#ファームウェアのバージョンとファームウェアのダウンロード|Phase 6]] | | モニタリング | ''Ctrl+M'' | [[:ja-jp_products:mp_studio:monitoring|Phase 7]] | | シミュレーション | — | [[:ja-jp_products:mp_studio:simulation|Phase 8]] | | 使用データ一覧 | — | [[:ja-jp_products:mp_studio:memory_symbols#使用データ一覧|Phase 5]] | | データテーブル | — | [[:ja-jp_products:mp_studio:monitoring#データテーブル|Phase 7]] | | プログラムメモリ容量 | — | [[:ja-jp_products:mp_studio:download#プログラムメモリ容量|Phase 6]] | | 強制入出力 | — | [[:ja-jp_products:mp_studio:monitoring#強制入出力|Phase 7]] | | EEPROM の初期化 | — | [[:ja-jp_products:mp_studio:download#eeprom_の初期化|Phase 6]] | | 機器の時計合わせ… | — | [[:ja-jp_products:mp_studio:device_clock|機器の時計(RTC)]] | | ニーモニック変換 | — | [[:ja-jp_products:mp_studio:download#ニーモニック変換|Phase 6]] | ===== 設定メニュー ===== {{ :ja-jp_products:mp_studio:menu-setting.png?480 |図5. 設定メニュー }} ^ 項目 ^ 動作 ^ | 通信ポート | ダウンロードチャンネルとシリアルチャンネルを設定します。[[:ja-jp_products:mp_studio:download#通信ポート|Phase 6]] | | 언어: 한국어・Language: English・言語: 日本語 | 画面の言語を切り替えます。 | | オプション | グリッド・フォント・色・ブランド名を設定します。 | | データメモリ | メモリ領域のサイズと停電保持区間を設定します。[[:ja-jp_products:mp_studio:memory_symbols#データメモリ|Phase 5]] | | シンボル | シンボルテーブルを開きます。[[:ja-jp_products:mp_studio:memory_symbols#シンボルテーブル|Phase 5]] | | LCD 画面エディタ | キャラクターLCDに表示する画面を作成します。作成した画面は、ラダーの''CSCR''ファンクションで表示します。[[:ja-jp_products:mp_studio:lcd_screen_editor|LCD 画面エディタ]] | | 7セグ画面エディタ | 7セグメント表示器に表示する画面を作成します。作成した画面は、ラダーの''FSCR''ファンクションで表示します。[[:ja-jp_products:mp_studio:seven_segment|7セグメント表示]] | | 機種選択 | 機種と拡張モジュールを選択します。[[:ja-jp_products:mp_studio:first_project#新規プロジェクトと機種の選択|Phase 1]] | | Modbus RTU マスター | Modbus RTU マスター通信を設定します。[[:ja-jp_products:mp_studio:modbus_device_table|Modbus 機器テーブル]] | | RTC(時計)… | 機器が外付けのDS3231モジュールの日時と状態を0.1秒ごとに書き込むD領域(16ワード)の開始アドレスを設定します。[[:ja-jp_products:mp_studio:device_clock|機器の時計(RTC)]] | | ユーザープロトコル… | Modbusを使わない機器とやり取りするフレームとトランザクションを、通信ポートごとに設定します(V1.3.0以降)。[[:ja-jp_products:mp_studio:user_protocol|ユーザープロトコル]] | | テーマ: モダンダーク・VS Code・ライト | 画面のテーマを切り替えます。 | ===== オプション ===== **設定 → オプション**を選択するか、上部バーの**環境設定**ボタンを押すと、オプションウィンドウが開きます。左側の目次で項目を選ぶと、右側に設定とプレビューが表示されます。 {{ :ja-jp_products:mp_studio:settings-dialog-marked.svg?1200 |図6. オプションウィンドウ }} * **① 設定の検索:** 設定名で項目を探します。 * **② 目次:** グリッドと二重コイル、フォント、色、ブランド名 * **③ 設定領域** * **④ プレビュー:** 変更した設定がラダーのプレビューにすぐ反映されます。 * **⑤ キャンセル・適用・OK:** **適用**はウィンドウを閉じずにすぐ反映します。左下の**色・フォントをすべて既定に戻す**は、上書きした色とフォントをすべて既定値に戻します。上書きした項目の数も併せて表示されます。 ^ 目次 ^ 設定 ^ | グリッドと二重コイル | セルの横・縦のサイズ、1行に並べるセルの数(1 行あたりの列数)、二重コイルのチェック | | フォント | グリッドのフォント(アドレス・シンボル・コメント・モニター値)、ヘッダーのフォント(行番号)、画面のフォント(メニュー・ウィンドウ)、コードのフォント(アドレスや値を等幅で表示する箇所) | | 色 | テーマ、ラダー、ファンクションブロック、モニター・チェック、画面の色 | | ブランド名 | ウィンドウのタイトルに表示する名前 | **1 行あたりの列数**は、そのプロジェクトにのみ適用されます。色を上書きすると、すべてのテーマに共通で適用されます。指定していない色は、選択したテーマに従います。印刷は用紙用の色(黒)に固定されます。 {{ :ja-jp_products:mp_studio:settings-colors.png?1080 |図7. 色 › ラダーの設定とプレビュー }} ===== テーマと言語 ===== **設定**メニューで、**テーマ: モダンダーク**、**テーマ: VS Code**、**テーマ: ライト**のいずれかを選択できます。 {{ :ja-jp_products:mp_studio:theme-modern.png?380 |モダンダーク}} {{ :ja-jp_products:mp_studio:theme-vscode.png?380 |VS Code}} {{ :ja-jp_products:mp_studio:theme-light.png?380 |ライト}} **設定**メニューの**言語: 日本語**・**Language: English**・**언어: 한국어**で、メニューとウィンドウの言語を切り替えます。3つの項目は、どの言語の画面でもそれぞれの言語で表示されるため、ほかの言語の画面からでも**言語: 日本語**を選べば日本語に戻せます。 {{ :ja-jp_products:mp_studio:language-english.png?1000 |図8. 設定メニューの言語の項目 }} ===== 印刷 ===== **プロジェクト → 印刷**(''Ctrl+P'')を選択すると、ラダーを印刷用のレイアウトにしてから、Windowsの印刷ダイアログを開きます。**ページ設定**と**印刷プレビュー**も、同じ印刷ダイアログを開きます。用紙の向き・余白・プリンターは、印刷ダイアログで選択してください。PDFで保存するには、プリンターとして**Microsoft Print to PDF**を選択してください。 {{ :ja-jp_products:mp_studio:print-page.png?1000 |図9. 印刷結果の1ページ }} ===== Modbus RTU マスター ===== **設定 → Modbus RTU マスター**を選択すると、設定ウィンドウが開きます。新しいプロジェクトと機器テーブルがあるプロジェクトでは[[:ja-jp_products:mp_studio:modbus_device_table|Modbus 機器テーブル]]ウィンドウが開き、従来のMP STUDIOで作成した一覧だけがあるプロジェクト(同梱のModbusサンプルなど)では、以下の一覧ウィンドウが開きます。このウィンドウでは、機器がModbus RTU マスターとして他の機器のレジスタを読み書きする一覧を設定します。 {{ :ja-jp_products:mp_studio:modbus-master-marked.svg?940 |図10. Modbus RTU マスターウィンドウ(同梱のModbusサンプル) }} - **① 通信ポート**で、マスターとして使用するチャンネル(**通信ポート1**~**通信ポート3**)を選択し、ボーレート・データビット・ストップビット・パリティ・タイムアウト(×10ms)・遅延時間(ms)を設定します。 - **② 追加**を押して項目を追加します。**並べ替え**は項目を並べ替えます。 - **③ 項目表**で、行ごとに**Modbus コード**(例:''WORD READ ( FC03 )''・''WORD WRITE ( FC06 )'')、**局番**、**アドレス**、**バインド**(値をやり取りする機器のメモリ。例:''D10'')、**説明**を入力します。行の右側の**削除**を押すと、その項目が削除されます。 - **OK**を押して保存します。 OKを押すと、選択したチャンネルの通信設定が上の値に変わり、モードが''Modbus RTU Master''に設定されます。また、そのチャンネルのダウンロードの使用がオフになります。 ウィンドウ左下の**テーブルへ移す**を押すと、この一覧を[[:ja-jp_products:mp_studio:modbus_device_table|Modbus 機器テーブル]]へ移します。移すとコンパイル結果のバイトが変わります(機器テーブルの新しい通信方式になります)。**編集 → 元に戻す**(''Ctrl+Z'')で元に戻せます。 ===== 自動保存と復元 ===== MP STUDIO 2は、編集中のプロジェクトを自動で保存しています。保存せずにプログラムが終了した場合は、次回の起動時に**自動保存の復元**ウィンドウが表示されます。 * **はい:** 自動保存データを開きます。 * **いいえ:** 自動保存データを削除します。 * **キャンセル:** 自動保存データを削除せずに残します。後で**プロジェクト → 自動保存の復元…**から開けます。 {{ :ja-jp_products:mp_studio:autosave-recover.png?440 |図11. 自動保存の復元ウィンドウ }} ===== ヘルプメニュー ===== {{ :ja-jp_products:mp_studio:menu-help.png?528 |図12. ヘルプメニュー }} ^ 項目 ^ 動作 ^ | MP STUDIO 2 のバージョン情報 | プログラムのバージョンと情報を表示します。 | | ホームページ | ILOGICSのホームページを開きます。 | | SW マニュアル | ソフトウェアのマニュアルを開きます。 | | HW マニュアル | 選択した機種のハードウェア取扱説明書を開きます。 | | 問題を報告… | 問題を説明し、スクリーンショットやプロジェクトファイルを添付して開発元へ送信します。 | | 改善を要望… | 希望する機能や改善点を開発元へ送信します。 | | エラーレポートを自動送信 | オン(✓)のときは、エラーが発生すると診断情報を自動で送信します。 | ==== 問題を報告 ==== {{ :ja-jp_products:mp_studio:bug-report-marked.svg?625 |図13. 問題を報告ウィンドウ }} - **① 何が起きたか**を入力してください(必須)。 - 必要に応じて、**② 開いているプロジェクト(.mpx)を添付**と**③ スクリーンショットを添付**を選択します。診断情報(ログ・システム情報)は常に一緒に送信されます。 - 返信を希望する場合は、**④ 返信用の連絡先を残す**を選択し、メールアドレスまたは電話番号を入力します。 - **送信**を押します。 プログラムが異常終了した後に再び起動すると、何をしていたかを尋ねるウィンドウが表示されることがあります。 ===== 関連文書 ===== * [[:ja-jp_products:mp_studio:quick_reference|クイックリファレンス · ショートカット]] * [[:ja-jp_products:mp_studio:troubleshooting|Phase 10 · トラブルシューティング]] [[:ja-jp_products:mp_studio|← MP STUDIO 2 ユーザーマニュアルに戻る]]