User Tools

Site Tools


en-us_products:mpino_studio2:menus_settings

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revisionPrevious revision
Next revision
Previous revision
en-us_products:mpino_studio2:menus_settings [2026/09/11 11:36] – 바깥 편집 127.0.0.1en-us_products:mpino_studio2:menus_settings [2026/09/12 21:42] (current) – 바깥 편집 127.0.0.1
Line 8: Line 8:
  
 The menu bar contains **File, Edit, View, Run, Settings, and Help**. Use **File** for project files, **Edit** for ladder-cell operations, and **View** to show or hide areas of the window. The menu bar contains **File, Edit, View, Run, Settings, and Help**. Use **File** for project files, **Edit** for ladder-cell operations, and **View** to show or hide areas of the window.
- 
-{{ :en-us_products:mpino_studio2:menu-purpose-map.svg?1000 |Purpose of the six menus }} 
  
 {{ :en-us_products:mpino_studio2:menu-bar-marked.svg?1000 |The actual MPINO Studio 2 menu bar }} {{ :en-us_products:mpino_studio2:menu-bar-marked.svg?1000 |The actual MPINO Studio 2 menu bar }}
  
-  * **①** File +^ Marker ^ Menu ^ Use it for ^ 
-  * **②** Edit +| **①** | File | Creating, opening, saving, and printing projects; opening Preferences; quitting the application | 
-  * **③** View +| **②** | Edit | Undoing, cutting, copying, pasting, and deleting ladder cells | 
-  * **④** Run +| **③** | View | Showing or hiding the sidebar, bottom panel, and ladder monitoring | 
-  * **⑤** Settings +| **④** | Run | Building, uploading, configuring communications, and writing memory values | 
-  * **⑥** Help +| **⑤** | Settings | Configuring memory areas, ladder design, pin maps, the board, and EEPROM retention | 
- +| **⑥** | Help | Reporting bugs, requesting improvements, checking for updates, and viewing application information |
-^ Menu ^ Use it for ^ +
-| File | Creating, opening, saving, and printing projects; opening Preferences; quitting the application | +
-| Edit | Undoing, cutting, copying, pasting, and deleting ladder cells | +
-| View | Showing or hiding the sidebar, bottom panel, and ladder monitoring | +
-| Run | Building, uploading, configuring communications, and writing memory values | +
-| Settings | Configuring memory areas, ladder design, pin maps, the board, and EEPROM retention | +
-| Help | Reporting bugs, requesting improvements, checking for updates, and viewing application information |+
  
 **File → Preferences** opens settings used on this PC. The top-level **Settings** menu combines project settings with an entry to the shared **Ladder Design** preferences. **File → Preferences** opens settings used on this PC. The top-level **Settings** menu combines project settings with an entry to the shared **Ladder Design** preferences.
Line 36: Line 27:
 {{ :en-us_products:mpino_studio2:menu-file-marked.svg?1000 |File menu items and shortcuts }} {{ :en-us_products:mpino_studio2:menu-file-marked.svg?1000 |File menu items and shortcuts }}
  
-  * **①** New and Open +^ Marker ^ Item ^ Default shortcut ^ Action ^ 
-  **②** Save and Save As +**①** New | ''Ctrl + N'' | Select a board and create a project. | 
-  * **** Print +**②** | Open | ''Ctrl + O'' | Open a saved ''.mp2'' project. | 
-  * **④** Preferences +| **③** | Save | ''Ctrl + S''Save the current project to its existing path. | 
-  * **** Quit+**** | Save As | ''Ctrl + Shift + S'' | Choose a new path and project filename. | 
 +**⑤** | Print | ''Ctrl + P''Print Arduino Code or ladder logic according to the active tab. | 
 +**** Preferences | - | Open the **General** tab in Settings. | 
 +| **⑦** Quit | - | Close MPINO Studio 2. |
  
-^ Item ^ Default shortcut ^ Action ^ +**Open** accepts ''.mp2'' projects saved by MPINO Studio 2It cannot open project files from MPINO STUDIO 1.x. Create a new project and transfer the previous contents after checking them.
-| New | ''Ctrl + N'' | Select a board and create a project. | +
-Open | ''Ctrl + O'' | Open a saved ''.mp2'' project+
-| Save | ''Ctrl + S'' | Save the current project to its existing path+
-| Save As | ''Ctrl + Shift + S'' | Choose a new path and project filename. | +
-| Print | ''Ctrl + P'' | Print Arduino Code or ladder logic according to the active tab. | +
-| Preferences | - | Open the **General** tab in Settings. | +
-| Quit | - | Close MPINO Studio 2|+
  
 If the current project has unsaved changes, **New** and **Open** first ask whether to discard them. Canceling that prompt or the following file or board picker keeps the current project open. If the current project has unsaved changes, **New** and **Open** first ask whether to discard them. Canceling that prompt or the following file or board picker keeps the current project open.
Line 73: Line 60:
 {{ :en-us_products:mpino_studio2:settings-general-marked.svg?1000 |User Library Folder, Platform Folder, Language, and Error reporting settings }} {{ :en-us_products:mpino_studio2:settings-general-marked.svg?1000 |User Library Folder, Platform Folder, Language, and Error reporting settings }}
  
-  * **①** User Library Folder +^ Marker ^ Item ^ Action ^ 
-  * **②** Platform Folder +| **①** | User Library Folder | Choose the location used to install, import, and open libraries. | 
-  * **③** Language +| **②** | Platform Folder | Open the ILOGICS board-core and toolchain folder used for builds and completion. | 
-  * **④** Automatic error reports +| **③** | Language | Select 한국어, English, or 日本語. | 
- +| **④** | Send error reports automatically | Choose whether diagnostics are sent after crashes and errors. |
-^ Item ^ Action ^ +
-| User Library Folder | Choose the location used to install, import, and open libraries. | +
-| Platform Folder | Open the ILOGICS board-core and toolchain folder used for builds and completion. | +
-| Language | Select 한국어, English, or 日本語. | +
-| Send error reports automatically | Choose whether diagnostics are sent after crashes and errors. |+
  
 Changing the **User Library Folder** does not move files from the previous folder. MPINO Studio 2 reloads the library list and restarts completion after the path changes. **Restore Default** returns the path to its default location. Changing the **User Library Folder** does not move files from the previous folder. MPINO Studio 2 reloads the library list and restarts completion after the path changes. **Restore Default** returns the path to its default location.
Line 94: Line 76:
 {{ :en-us_products:mpino_studio2:settings-shortcuts-marked.svg?1000 |Shortcut change, reset, and conflict areas }} {{ :en-us_products:mpino_studio2:settings-shortcuts-marked.svg?1000 |Shortcut change, reset, and conflict areas }}
  
-  * **①** Reset all to defaults +^ Marker ^ Screen area ^ Action or configurable function ^ 
-  **②** Command and current shortcut +**①** Reset all to defaults | Restore all 16 customized shortcuts to their defaults. | 
-  **③** Change or reset one item +**②** | Function and current shortcut | Show the key combination currently assigned to each function. | 
- +**③** Change or reset one item | Change the selected shortcut or restore its default. | 
-^ Group ^ Configurable commands ^ +| - | Monitoring | Toggle Monitoring | 
-| Monitoring | Toggle Monitoring | +| - | Ladder elements | NO and NC contacts, horizontal and vertical lines, standard, SET, and RESET coils, NOT, rising and falling edges, and box functions | 
-| Ladder elements | NO and NC contacts, horizontal and vertical lines, output, SET, and RESET coils, NOT, positive and negative edges, and box functions | +| - | Structure editing | Insert or delete cellsand add or delete rows |
-| Structure editing | Insert and delete cells; insert and delete rows |+
  
   - Select **Change** for the command.   - Select **Change** for the command.
Line 113: Line 94:
 {{ :en-us_products:mpino_studio2:shortcut-conflict.svg?1000 |Conflict notice and execution priority for duplicate shortcuts }} {{ :en-us_products:mpino_studio2:shortcut-conflict.svg?1000 |Conflict notice and execution priority for duplicate shortcuts }}
  
-  * **①** Entered shortcut +^ Marker ^ Screen area ^ Action ^ 
-  **②** Conflicting command notice +**①** Entered shortcut | Show the key or key combination being registered. | 
-  **③** Confirm or cancel+**②** Conflicting command notice | Show the function already using the shortcut. The function registered first runs. | 
 +**③** Confirm or cancel | Confirm the entered shortcut or cancel the change. |
  
 See [[en-us_products:mpino_studio2:ladder_editing#ladder_editing_shortcuts|Phase 3 · Ladder Editing Shortcuts]] for the result of each ladder shortcut. See [[en-us_products:mpino_studio2:ladder_editing#ladder_editing_shortcuts|Phase 3 · Ladder Editing Shortcuts]] for the result of each ladder shortcut.
Line 125: Line 107:
 {{ :en-us_products:mpino_studio2:settings-ladder-marked.svg?1000 |Symbol display, Use Ladder, Duplicate coil check, automatic input box, and monitoring port }} {{ :en-us_products:mpino_studio2:settings-ladder-marked.svg?1000 |Symbol display, Use Ladder, Duplicate coil check, automatic input box, and monitoring port }}
  
-  * **①** Address and symbol display +^ Marker ^ Item ^ Action ^ Scope ^ 
-  * **②** Use Ladder +| **①** | Address + symbol | Show the symbol and address together in each ladder cell. | This PC | 
-  * **③** Duplicate coil check +| **②** | Symbol only | Show the symbol when one exists, and the address otherwise. | This PC | 
-  * **④** Input box after contact creation +| **③** | Use Ladder | When cleared, exclude ladder logic from the build and use Arduino Code only. | This PC | 
-  * **⑤** Monitoring Port +| **④** | Duplicate coil check | Report a build error when two or more output coils use the same address. | This PC | 
- +| **⑤** | Auto input box on contact creation | Open the address input box immediately after creating a contact or edge. | This PC | 
-^ Item ^ Action ^ Scope ^ +| **⑥** | Monitoring port | Select the board serial channel that sends ladder-monitoring data. | Current project |
-| Address + symbol | Show the symbol and address together in each ladder cell. | This PC | +
-| Symbol only | Show the symbol when one exists, and the address otherwise. | This PC | +
-| Use Ladder | When cleared, exclude ladder logic from the build and use Arduino Code only. | This PC | +
-| Duplicate coil check | Report a build error when two or more output coils use the same address. | This PC | +
-| Auto input box on contact creation | Open the address input box immediately after creating a contact or edge. | This PC | +
-| Monitoring port | Select the board serial channel that sends ladder-monitoring data. | Current project |+
  
 Clearing **Use Ladder** does not delete ladder tabs. It excludes only the generated ladder code from the build. Clearing **Use Ladder** does not delete ladder tabs. It excludes only the generated ladder code from the build.
Line 151: Line 127:
 {{ :en-us_products:mpino_studio2:settings-design-marked.svg?1000 |Ladder colors, cell dimensions, text size, line width, and Save }} {{ :en-us_products:mpino_studio2:settings-design-marked.svg?1000 |Ladder colors, cell dimensions, text size, line width, and Save }}
  
-  * **①** Colors +^ Marker ^ Color ^ Current use ^ 
-  **②** Cell dimensions and columns +**①** | Cell color | Ladder-cell background | 
-  * **** Text size and line width +**②** | Selected cell color | Selected ladder cell | 
-  * **** Factory Reset and Save+| **③** | Line color | Contacts, connection lines, and coils | 
 +**** | Text color | Addresses and box-function text | 
 +| **⑤** | Symbol color | Marked **planned** and not currently applied to the ladder. | 
 +| **⑥** | Monitoring color | Marked **planned** and not currently applied to the ladder. | 
 + 
 +^ Marker ^ Item ^ Default ^ Allowed range ^ 
 +| **⑦** | Width | 100px | 100–240px | 
 +| **⑧** | Height | 60px | 40–120px | 
 +| **⑨** | Columns | 12 | 4–32 | 
 +| **⑩** Text size | 13px | 9–24px | 
 +**** | Line width | 2 | 1–4 in 0.5 steps | 
 +**⑫** | Factory Reset | - | Restore the input fields to their defaults. | 
 +| **⑬** | Save | - | Apply the entered design to the selected theme on this PC. |
  
 {{ :en-us_products:mpino_studio2:ladder-design-before-after.svg?1000 |Ladder design before and after saving }} {{ :en-us_products:mpino_studio2:ladder-design-before-after.svg?1000 |Ladder design before and after saving }}
- 
-^ Color ^ Current use ^ 
-| Cell color | Ladder-cell background | 
-| Selected cell color | Selected ladder cell | 
-| Line color | Contacts, connection lines, and coils | 
-| Text color | Addresses and box-function text | 
-| Symbol color | Marked **planned** and not currently applied to the ladder. | 
-| Monitoring color | Marked **planned** and not currently applied to the ladder. | 
- 
-^ Item ^ Default ^ Allowed range ^ 
-| Width | 100px | 100–240px | 
-| Height | 60px | 40–120px | 
-| Columns | 12 | 4–32 | 
-| Text size | 13px | 9–24px | 
-| Line width | 2 | 1–4 in 0.5 steps | 
  
 Enter colors in ''#RRGGBB'' format. **Save** is disabled when a number is outside its range or a color is invalid. Enter colors in ''#RRGGBB'' format. **Save** is disabled when a number is outside its range or a color is invalid.
Line 183: Line 156:
 {{ :en-us_products:mpino_studio2:menu-edit-view-marked.svg?1000 |Edit and View menus }} {{ :en-us_products:mpino_studio2:menu-edit-view-marked.svg?1000 |Edit and View menus }}
  
-  * **①** Undo +^ Marker ^ Edit item ^ Default shortcut ^ Action ^ 
-  * **②** Cut, Copy, Paste, and Delete +| **①** | Undo | ''Ctrl + Z'' | Undo the most recent ladder edit. | 
-  * **③** Sidebar and panel visibility +| **②** | Cut | ''Ctrl + X'' | Copy the selected ladder cells and clear the originals. | 
-  * **④** Monitoring visibility +| **③** | Copy | ''Ctrl + C'' | Copy the selected ladder cells. | 
- +| **④** | Paste | ''Ctrl + V'' | Paste copied cells at the current selection. | 
-^ Edit item ^ Default shortcut ^ Action ^ +| **⑤** | Delete | ''Delete'' | Clear the selected ladder cells. |
-| Undo | ''Ctrl + Z'' | Undo the most recent ladder edit. | +
-| Cut | ''Ctrl + X'' | Copy the selected ladder cells and clear the originals. | +
-| Copy | ''Ctrl + C'' | Copy the selected ladder cells. | +
-| Paste | ''Ctrl + V'' | Paste copied cells at the current selection. | +
-| Delete | ''Delete'' | Clear the selected ladder cells. |+
  
-^ View item ^ Default shortcut ^ Action ^ +^ Marker ^ View item ^ Default shortcut ^ Action ^ 
-| Toggle Sidebar | ''Ctrl + B'' | Show or hide the left sidebar. | +| **⑥** | Toggle Sidebar | ''Ctrl + B'' | Show or hide the left sidebar. | 
-| Toggle Panel | ''Ctrl + J'' | Show or hide the bottom panel below the editor. | +| **⑦** | Toggle Panel | ''Ctrl + J'' | Show or hide the bottom panel below the editor. | 
-| Toggle Monitoring | ''Ctrl + M'' | Start or stop ladder monitoring. |+| **⑧** | Toggle Monitoring | ''Ctrl + M'' | Start or stop ladder monitoring. |
  
 Cut, Copy, Paste, and Delete in the top **Edit** menu apply to ladder tabs. To edit Arduino Code text, use the same shortcuts while focus is in the code editor. Cut, Copy, Paste, and Delete in the top **Edit** menu apply to ladder tabs. To edit Arduino Code text, use the same shortcuts while focus is in the code editor.
Line 212: Line 180:
 {{ :en-us_products:mpino_studio2:menu-run-marked.svg?1000 |Build, Upload, Communication, and Memory Write List in the Run menu }} {{ :en-us_products:mpino_studio2:menu-run-marked.svg?1000 |Build, Upload, Communication, and Memory Write List in the Run menu }}
  
-  * **①** Build and Upload +^ Marker ^ Item ^ Default shortcut ^ Action ^ 
-  * **②** Cancel Upload +| **①** | Build | ''Ctrl + R'' | Transpile and compile the current editor content. | 
-  * **③** Communication +| **②** | Upload | ''Ctrl + U'' | Build the current content and upload it through the selected port. | 
-  * **④** Memory Write List +| **③** | Cancel Upload | - | Stop an upload in progress. | 
- +| **④** | Communication | - | Configure serial communication channels on the board. | 
-^ Item ^ Default shortcut ^ Action ^ +| **⑤** | Memory Write List | - | View and change memory values on the running board. |
-| Build | ''Ctrl + R'' | Transpile and compile the current editor content. | +
-| Upload | ''Ctrl + U'' | Build the current content and upload it through the selected port. | +
-| Cancel Upload | - | Stop an upload in progress. | +
-| Communication | - | Configure serial communication channels on the board. | +
-| Memory Write List | - | View and change memory values on the running board. |+
  
 See [[en-us_products:mpino_studio2:first_project#build_the_project|Phase 1 · Build the Project]] for building, port selection, and upload. See [[en-us_products:mpino_studio2:first_project#build_the_project|Phase 1 · Build the Project]] for building, port selection, and upload.
Line 232: Line 195:
 {{ :en-us_products:mpino_studio2:communication-settings-marked.svg?1000 |Communication channel, protocol, Slave ID, and serial settings }} {{ :en-us_products:mpino_studio2:communication-settings-marked.svg?1000 |Communication channel, protocol, Slave ID, and serial settings }}
  
-  * **①** Communication channel +^ Marker ^ Item ^ Setting ^ 
-  * **②** Protocol +| **①** | Channel | ''Serial1'', ''Serial2'', and ''Serial3'' channels provided by the board | 
-  * **③** Slave ID +| **②** | Protocol | None, Modbus RTU Slave, or LS Electric Cnet Slave | 
-  * **④** Baud, data bits, stop bits, and parity +| **③** | Slave ID | 1–247 | 
- +| **④** | Baud Rate | Baud used by the channel | 
-^ Item ^ Setting ^ +| **⑤** | Data Bits | 5, 6, 7, or 8 | 
-| Channel | ''Serial1'', ''Serial2'', and ''Serial3'' channels provided by the board | +| **⑥** | Stop Bits | 1 or 2 | 
-| Protocol | None, Modbus RTU Slave, or LS Electric Cnet Slave | +| **⑦** | Parity | None, Even, or Odd |
-| Slave ID | 1–247 | +
-| Baud Rate | Baud used by the channel | +
-| Data Bits | 5, 6, 7, or 8 | +
-| Stop Bits | 1 or 2 | +
-| Parity | None, Even, or Odd |+
  
 Select **None** to leave the channel unused. Selecting **Modbus RTU Slave** or **LS Electric Cnet Slave** enables the Slave ID and serial settings. The defaults are Slave ID 1, 115200bps, 8 data bits, 1 stop bit, and no parity. Select **None** to leave the channel unused. Selecting **Modbus RTU Slave** or **LS Electric Cnet Slave** enables the Slave ID and serial settings. The defaults are Slave ID 1, 115200bps, 8 data bits, 1 stop bit, and no parity.
Line 260: Line 218:
 {{ :en-us_products:mpino_studio2:memory-write-list-marked.svg?1000 |Address input, Current, Value, row Write, and Write All }} {{ :en-us_products:mpino_studio2:memory-write-list-marked.svg?1000 |Address input, Current, Value, row Write, and Write All }}
  
-  * **①** Monitoring connection +^ Marker ^ Screen area or function ^ Action ^ 
-  **②** Address, value, and Write +**①** Monitoring connection | Connect ladder monitoring first and check its current connection state. | 
-  * **③** Import, Export, and Clear +**②** Address, value, and Write | Enter a memory address and value, then select **Write** or press ''Enter''| 
-  * **④** Write or delete one row +| **③** | ImportExportClear, and Write All | Load or save a list, clear it, or write every row containing a value from top to bottom. | 
-  * **⑤** Current and write values +| **④** | Row Write and Delete | Write only the selected row or remove it from the list without changing the board value. | 
- +**⑤** Current and write values | Check the current board value and the value prepared for writing. |
-{{ :en-us_products:mpino_studio2:memory-write-workflow.svg?1000 |Enter an address and value, write to the board, and verify the current value }} +
- +
-  - Connect ladder monitoring. +
-  - Enter a memory address and value in the input row. +
-  - Select **Write** or press ''Enter''. +
-  - Confirm that the registered address and current value appear in the list. +
- +
-^ Item ^ Action ^ +
-| Import | Replace the current list with a list from a file. | +
-Export | Save the current list to a file. | +
-Clear | Delete every registered row after confirmation. | +
-Write All | Write every row that contains a valuefrom top to bottom. | +
-| Row Write | Write only that row to the board. | +
-Row Delete Remove the row from the list without changing board memory. |+
  
 An address cannot be registered twice. A row cannot be written when its address is invalid or outside the current board's memory range. **Write All** skips empty values and stops at the first failed row. An address cannot be registered twice. A row cannot be written when its address is invalid or outside the current board's memory range. **Write All** skips empty values and stops at the first failed row.
Line 295: Line 239:
 {{ :en-us_products:mpino_studio2:menu-settings-marked.svg?1000 |Six items in the Settings menu }} {{ :en-us_products:mpino_studio2:menu-settings-marked.svg?1000 |Six items in the Settings menu }}
  
-  * **①** Memory Area Settings +^ Marker ^ Item ^ Default shortcut ^ Saved for ^ Description ^ 
-  * **②** Ladder Design Settings +| **①** | Memory Area Settings | ''Ctrl + Shift + M'' | Current project | Set the number of P, M, D, C, T, and R memory entries. | 
-  * **③** Ladder Pin Map Settings +| **②** | Ladder Design Settings | ''Ctrl + Shift + D'' | This PC | Open Ladder Design preferences. | 
-  * **④** Change Board +| **③** | Ladder Pin Map Settings | ''Ctrl + Shift + P'' | Current project | Edit the mapping between board pins and ladder addresses. | 
-  * **⑤** Used Memory +| **④** | Change Board | - | Current project | Change the target board for the current project. | 
-  * **⑥** EEPROM Retention +| **⑤** | Used Memory | ''Ctrl + Shift + L'' | View only | Find memory addresses and their references in the project. | 
- +| **⑥** | EEPROM Retain | ''Ctrl + Shift + E'' | Current project | Select memory areas retained after power is removed. |
-^ Item ^ Default shortcut ^ Saved for ^ Description ^ +
-| Memory Area Settings | ''Ctrl + Shift + M'' | Current project | Set the number of P, M, D, C, T, and R memory entries. | +
-| Ladder Design Settings | ''Ctrl + Shift + D'' | This PC | Open Ladder Design preferences. | +
-| Ladder Pin Map Settings | ''Ctrl + Shift + P'' | Current project | Edit the mapping between board pins and ladder addresses. | +
-| Change Board | - | Current project | Change the target board for the current project. | +
-| Used Memory | ''Ctrl + Shift + L'' | View only | Find memory addresses and their references in the project. | +
-| EEPROM Retain | ''Ctrl + Shift + E'' | Current project | Select memory areas retained after power is removed. |+
  
 See [[en-us_products:mpino_studio2:memory#memory_regions|Phase 2 · Memory Regions]] for Memory Area Settings and Used Memory. See [[#ladder_design|Ladder Design]] above for design settings. See [[en-us_products:mpino_studio2:memory#memory_regions|Phase 2 · Memory Regions]] for Memory Area Settings and Used Memory. See [[#ladder_design|Ladder Design]] above for design settings.
Line 318: Line 255:
 {{ :en-us_products:mpino_studio2:board-change-marked.svg?1000 |Current board and replacement board in the board picker }} {{ :en-us_products:mpino_studio2:board-change-marked.svg?1000 |Current board and replacement board in the board picker }}
  
-  * **①** Product family +^ Marker ^ Screen area ^ Action ^ 
-  **②** Board selection +**①** Product family | Select the product family containing the replacement board. | 
-  **③** Select or Cancel +**②** Board selection | Select the board and option-module configuration for the current project. | 
- +**③** Select or Cancel | Apply the selected board or close the window without changing it. |
-{{ :en-us_products:mpino_studio2:board-change-checklist.svg?1000 |Check the pin map, memory, and communication after changing the board }}+
  
 Pin maps, memory sizes, and communication channels can differ between boards. After changing the board, review **Memory Area Settings, Ladder Pin Map Settings, Communication, and Monitoring port**. Pin maps, memory sizes, and communication channels can differ between boards. After changing the board, review **Memory Area Settings, Ladder Pin Map Settings, Communication, and Monitoring port**.
Line 334: Line 270:
 {{ :en-us_products:mpino_studio2:ladder-pinmap-marked.svg?1000 |LD, Name, Pin, Direction and Function, Use, and Description columns }} {{ :en-us_products:mpino_studio2:ladder-pinmap-marked.svg?1000 |LD, Name, Pin, Direction and Function, Use, and Description columns }}
  
-  * **①** LD address +^ Marker ^ Column ^ Meaning ^ Editable ^ 
-  * **②** Name +| **①** | LD | P, M, D, C, or R address used by the ladder | Yes | 
-  * **③** Arduino pin number +| **②** | Name | Name used to identify the pin | Yes | 
-  * **④** Direction and function +| **③** | Pin | Pin number used by Arduino Code | Read only | 
-  * **⑤** Use and description +| **④** | Direction/Function | Input, output, analog, or another pin function | Read only | 
- +| **⑤** | Use | Whether the mapping is enabled in the current project | Yes | 
-^ Column ^ Meaning ^ Editable ^ +| **⑥** | Description | Description of the pin's purpose | Yes |
-| LD | P, M, D, C, or R address used by the ladder | Yes | +
-| Name | Name used to identify the pin | Yes | +
-| Pin | Pin number used by Arduino Code | Read only | +
-| Direction/Function | Input, output, analog, or another pin function | Read only | +
-| Use | Whether the mapping is enabled in the current project | Yes | +
-| Description | Description of the pin's purpose | Yes |+
  
 A pin with **Use** cleared is excluded from generated ladder I/O code. A build fails if the ladder references the LD address of a disabled pin. A pin with **Use** cleared is excluded from generated ladder I/O code. A build fails if the ladder references the LD address of a disabled pin.
Line 362: Line 292:
 {{ :en-us_products:mpino_studio2:eeprom-retain-marked.svg?1000 |Save options, power detect pin, memory range, EEPROM address, and usage }} {{ :en-us_products:mpino_studio2:eeprom-retain-marked.svg?1000 |Save options, power detect pin, memory range, EEPROM address, and usage }}
  
-  * **①** Save options +^ Marker ^ Screen area ^ Setting ^ 
-  **②** Power-detect pin and time +**①** Save options | Option 1 saves M, D, and C when values change. Option 2 saves M, D, C, and T when power loss is detected. Both options may be enabled. | 
-  **③** Retained memory ranges +**②** Power-detect pin and time | Set the input pin and detection time used by Option 2. | 
-  **④** EEPROM usage +**③** Retained ranges and EEPROM addresses | Enter the first and last memory addresses and the EEPROM start address for each area. | 
-  **⑤** Save or Cancel+**④** EEPROM usage | Check the configured usage and remaining capacity. | 
 +**⑤** Save or Cancel | Apply the settings to the current project or close the window without changing them. |
  
 {{ :en-us_products:mpino_studio2:eeprom-retain-memory-model.svg?1000 |Memory model for save-on-change and save-on-power-loss }} {{ :en-us_products:mpino_studio2:eeprom-retain-memory-model.svg?1000 |Memory model for save-on-change and save-on-power-loss }}
- 
-^ Option ^ Save trigger ^ Memory areas ^ Additional settings ^ 
-| Option 1 | When a value changes | M, D, and C | None | 
-| Option 2 | When power loss is detected | M, D, C, and T | Power detect pin and Detect time | 
  
 The two options are independent and can be enabled together. Option 2 requires a **Power detect pin** and at least one memory area. The two options are independent and can be enabled together. Option 2 requires a **Power detect pin** and at least one memory area.
Line 394: Line 321:
 {{ :en-us_products:mpino_studio2:menu-help-marked.svg?1000 |Report a Bug, Request an Improvement, Check for Updates, and About }} {{ :en-us_products:mpino_studio2:menu-help-marked.svg?1000 |Report a Bug, Request an Improvement, Check for Updates, and About }}
  
-  * **①** Report a Bug +^ Marker ^ Item ^ Action ^ 
-  **②** Request an Improvement +**①** Report a Bug | Send a problem description and diagnostics. | 
-  **③** Check for Updates +**②** Request an Improvement | Send a requested feature or improvement. | 
-  **④** About+**③** Check for Updates | Check whether a new update can be installed. | 
 +**④** About | Display application information. |
  
 {{ :en-us_products:mpino_studio2:bug-report-marked.svg?1000 |Bug description, diagnostics, and optional attachments }} {{ :en-us_products:mpino_studio2:bug-report-marked.svg?1000 |Bug description, diagnostics, and optional attachments }}
  
-  * **①** Problem description +^ Marker ^ Screen area ^ Action ^ 
-  **②** Basic diagnostics +**①** Problem description | Describe the problem and how to reproduce it. | 
-  **③** Optional attachments +**②** Basic diagnostics | Review the attached application version, operating system, and logs. | 
-  **④** Send or Cancel +**③** Optional attachments | Optionally attach the current project, a screenshot, and contact information. | 
- +**④** Send or Cancel | Send the report or close the window. |
-^ Item ^ Action ^ +
-| Report a Bug | Send a problem description and diagnostics. | +
-| Request an Improvement | Send a requested feature or improvement. | +
-| Check for Updates | Check whether a new update can be installed. | +
-| About | Display application information. |+
  
 A bug report sent from **Report a Bug** always includes basic diagnostics containing the application version, operating system, and logs. The current project, screenshot, and contact information are optional. A bug report sent from **Report a Bug** always includes basic diagnostics containing the application version, operating system, and logs. The current project, screenshot, and contact information are optional.
Line 463: Line 386:
   * [[en-us_products:mpino_studio2:code_editor|Phase 5 · Editing Arduino Code]] — code editing and file management   * [[en-us_products:mpino_studio2:code_editor|Phase 5 · Editing Arduino Code]] — code editing and file management
   * [[en-us_products:mpino_studio2:monitoring|Phase 6 · Serial and Ladder Monitoring]] — monitoring connections and port usage   * [[en-us_products:mpino_studio2:monitoring|Phase 6 · Serial and Ladder Monitoring]] — monitoring connections and port usage
 +  * [[en-us_products:mpino_studio2:activity_bar|Phase 8 · Activity Bar and Side Panels]] — Explorer, Ladder Settings, libraries, and symbols
   * [[en-us_products:mpino_studio2|MPINO STUDIO 2 User Manual]]   * [[en-us_products:mpino_studio2|MPINO STUDIO 2 User Manual]]
  
-[[en-us_products:mpino_studio2:monitoring|← Phase 6 · Serial and Ladder Monitoring]] | [[en-us_products:mpino_studio2|Back to the MPINO STUDIO 2 User Manual]]+[[en-us_products:mpino_studio2:monitoring|← Phase 6 · Serial and Ladder Monitoring]] | [[en-us_products:mpino_studio2:activity_bar|Phase 8 · Activity Bar and Side Panels →]] | [[en-us_products:mpino_studio2|Back to the MPINO STUDIO 2 User Manual]]
  
en-us_products/mpino_studio2/menus_settings.1789094177.txt.gz · Last modified: by 127.0.0.1

Donate Powered by PHP Valid HTML5 Valid CSS Driven by DokuWiki