ユーザ用ツール

サイト用ツール


ja-jp_products:mpino_studio2:menus_settings

差分

このページの2つのバージョン間の差分を表示します。

この比較画面へのリンク

次のリビジョン
前のリビジョン
ja-jp_products:mpino_studio2:menus_settings [2026/09/11 11:09] – 만듦 - 바깥 편집 127.0.0.1ja-jp_products:mpino_studio2:menus_settings [2026/09/12 21:42] (現在) – 바깥 편집 127.0.0.1
行 9: 行 9:
 メニューバーには**ファイル・編集・表示・実行・設定・ヘルプ**があります。プロジェクトファイルには**ファイル**、ラダーセルの操作には**編集**、画面領域の表示切替には**表示**を使用します。 メニューバーには**ファイル・編集・表示・実行・設定・ヘルプ**があります。プロジェクトファイルには**ファイル**、ラダーセルの操作には**編集**、画面領域の表示切替には**表示**を使用します。
  
-{{ :ja-jp_products:mpino_studio2:menu-purpose-map.svg?1000 |六つのメニューの役割 }}+{{ :ja-jp_products:mpino_studio2:menu-bar-marked.svg?1000 |MPINO Studio 2の実際のメニューバー }}
  
-^ メニュー ^ 使用する機能 ^ +^ マーカー ^ メニュー ^ 使用する機能 ^ 
-| ファイル | プロジェクトの作成・オープン・保存・印刷、環境設定、プログラムの終了 | +| **①** | ファイル | プロジェクトの作成・オープン・保存・印刷、環境設定、プログラムの終了 | 
-| 編集 | ラダーセルの元に戻す・切り取り・コピー・貼り付け・削除 | +| **②** | 編集 | ラダーセルの元に戻す・切り取り・コピー・貼り付け・削除 | 
-| 表示 | サイドバー・下部パネル・ラダーモニタリングの表示切替 | +| **③** | 表示 | サイドバー・下部パネル・ラダーモニタリングの表示切替 | 
-| 実行 | ビルド・書き込み・通信設定・メモリ書き込み | +| **④** | 実行 | ビルド・書き込み・通信設定・メモリ書き込み | 
-| 設定 | メモリ領域・ラダーデザイン・ピンマップ・ボード・EEPROMの設定 | +| **⑤** | 設定 | メモリ領域・ラダーデザイン・ピンマップ・ボード・EEPROMの設定 | 
-| ヘルプ | バグ報告・改善要望・アップデート確認・プログラム情報 |+| **⑥** | ヘルプ | バグ報告・改善要望・アップデート確認・プログラム情報 |
  
 **ファイル → 環境設定**は、このPCで使用するプログラム環境を開きます。上部の**設定**メニューには、現在のプロジェクトに保存される設定と共通の**ラダーデザイン**環境設定への項目があります。 **ファイル → 環境設定**は、このPCで使用するプログラム環境を開きます。上部の**設定**メニューには、現在のプロジェクトに保存される設定と共通の**ラダーデザイン**環境設定への項目があります。
行 27: 行 27:
 {{ :ja-jp_products:mpino_studio2:menu-file-marked.svg?1000 |ファイルメニューの項目とショートカット }} {{ :ja-jp_products:mpino_studio2:menu-file-marked.svg?1000 |ファイルメニューの項目とショートカット }}
  
-^ 項目 ^ 既定のショートカット ^ 動作 ^ +^ マーカー ^ 項目 ^ 既定のショートカット ^ 動作 ^ 
-| 新規作成 | ''Ctrl + N'' | ボードを選択して新しいプロジェクトを作成します。 | +| **①** | 新規作成 | ''Ctrl + N'' | ボードを選択して新しいプロジェクトを作成します。 | 
-| 開く | ''Ctrl + O'' | 保存されている''.mp2''プロジェクトを開きます。 | +| **②** | 開く | ''Ctrl + O'' | 保存されている''.mp2''プロジェクトを開きます。 | 
-| 保存 | ''Ctrl + S'' | 現在のプロジェクトを既存のパスに保存します。 | +| **③** | 保存 | ''Ctrl + S'' | 現在のプロジェクトを既存のパスに保存します。 | 
-| 名前を付けて保存 | ''Ctrl + Shift + S'' | 保存場所とプロジェクトファイル名を指定し直します。 | +| **④** | 名前を付けて保存 | ''Ctrl + Shift + S'' | 保存場所とプロジェクトファイル名を指定し直します。 | 
-| 印刷 | ''Ctrl + P'' | アクティブなタブに応じてArduino Codeまたはラダーロジックを印刷します。 | +| **⑤** | 印刷 | ''Ctrl + P'' | アクティブなタブに応じてArduino Codeまたはラダーロジックを印刷します。 | 
-| 環境設定 | - | 設定画面の**一般**タブを開きます。 | +| **⑥** | 環境設定 | - | 設定画面の**一般**タブを開きます。 | 
-| 終了 | - | MPINO Studio 2を終了します。 |+| **⑦** | 終了 | - | MPINO Studio 2を終了します。 | 
 + 
 +**開く**はMPINO Studio 2で保存した''.mp2''プロジェクトを対象とします。従来のMPINO STUDIO 1.xのプロジェクトファイルは開けません。新しいプロジェクトを作成し、以前の内容を確認しながら移してください。
  
 保存されていない変更がある場合、**新規作成**と**開く**を実行する前に変更を破棄するか確認します。確認画面、または続いて開くファイル・ボード選択画面を取り消すと、現在のプロジェクトを維持します。 保存されていない変更がある場合、**新規作成**と**開く**を実行する前に変更を破棄するか確認します。確認画面、または続いて開くファイル・ボード選択画面を取り消すと、現在のプロジェクトを維持します。
行 43: 行 45:
  
 新しいプロジェクトの作成とボード選択は[[ja-jp_products:mpino_studio2:first_project|Phase 1・最初のプロジェクトを作る]]で確認できます。 新しいプロジェクトの作成とボード選択は[[ja-jp_products:mpino_studio2:first_project|Phase 1・最初のプロジェクトを作る]]で確認できます。
- 
-> **保存の注意:** **終了**は保存されていない変更を確認せずにプログラムを閉じます。終了する前に''Ctrl + S''で保存してください。 
  
 ===== 3. 環境設定 ===== ===== 3. 環境設定 =====
行 50: 行 50:
 **ファイル → 環境設定**を選択すると、**設定**画面の**一般**タブが開きます。上部の**一般・ショートカット・ラダー設定・ラダーデザイン**でタブを切り替えます。 **ファイル → 環境設定**を選択すると、**設定**画面の**一般**タブが開きます。上部の**一般・ショートカット・ラダー設定・ラダーデザイン**でタブを切り替えます。
  
-^ タブ ^ 適用範囲 ^ 反映時期 ^ 保存方法 ^ +**一般ショートカット・ラダー設定**の変更はすぐに反映され、このPCのプログラム設自動保存されます。ただし、**モニタリング使用ポート**は現在のプロジェクトに保存され変更しポートをボードへ反映するに再度ビルド・書き込みが必要です。 
-一般 | このPC | 項目を変更した直後 | 自動保存 | + 
-ショートカット このPC | ショートカットを確した直後 | 自動保存 +**ラダーデザイン**は入力中には反映されません。色とサイズを指定した後に**保存**を選択すると、このPCで選択中のテーマ適用されます。
-| ラダー設定 | モニタリングポートは現在のプロジェクト、その他はこのPC | 即時または次回のビルド・書き込み | PC設定は自動保存、モニタリングポートはプロジェクト保存 | +
-ラダーデザイン | このPCの現在のテーマ | **保存**を選択した後 | 設定ファイル保存 |+
  
 ==== 一般 ==== ==== 一般 ====
行 62: 行 60:
 {{ :ja-jp_products:mpino_studio2:settings-general-marked.svg?1000 |ユーザーライブラリフォルダ・プラットフォームフォルダ・言語・エラーレポートの設定 }} {{ :ja-jp_products:mpino_studio2:settings-general-marked.svg?1000 |ユーザーライブラリフォルダ・プラットフォームフォルダ・言語・エラーレポートの設定 }}
  
-^ 項目 ^ 動作 ^ +^ マーカー ^ 項目 ^ 動作 ^ 
-| ユーザーライブラリフォルダ | ライブラリのインストール・取り込み・フォルダを開く操作で使用する場所を指定します。 | +| **①** | ユーザーライブラリフォルダ | ライブラリのインストール・取り込み・フォルダを開く操作で使用する場所を指定します。 | 
-| プラットフォームフォルダ | ビルドと自動補完で使用するILOGICSボードコア・ツールチェーンのフォルダを開きます。 | +| **②** | プラットフォームフォルダ | ビルドと自動補完で使用するILOGICSボードコア・ツールチェーンのフォルダを開きます。 | 
-| 言語 | 한국어・English・日本語から選択します。 | +| **③** | 言語 | 한국어・English・日本語から選択します。 | 
-| エラーレポートを自動送信 | 異常終了やエラー発生時に診断情報を自動送信するか選択します。 |+| **④** | エラーレポートを自動送信 | 異常終了やエラー発生時に診断情報を自動送信するか選択します。 |
  
 **ユーザーライブラリフォルダ**を変更しても、以前のフォルダにあるファイルは移動しません。変更後はライブラリ一覧を再読み込みし、自動補完エンジンを再起動します。**デフォルトに戻す**はフォルダを既定の場所に戻します。 **ユーザーライブラリフォルダ**を変更しても、以前のフォルダにあるファイルは移動しません。変更後はライブラリ一覧を再読み込みし、自動補完エンジンを再起動します。**デフォルトに戻す**はフォルダを既定の場所に戻します。
行 78: 行 76:
 {{ :ja-jp_products:mpino_studio2:settings-shortcuts-marked.svg?1000 |ショートカットの変更・リセット・競合表示 }} {{ :ja-jp_products:mpino_studio2:settings-shortcuts-marked.svg?1000 |ショートカットの変更・リセット・競合表示 }}
  
-区分 ^ 変更できる機能 ^ +マーカー 画面領域 ^ 動作・変更できる機能 ^ 
-| モニタリング | モニタリング切替 | +| **①** | すべて既定値に戻す | 変更した16個のショートカットをすべて既定値に戻します。 | 
-| ラダー要素 | NO・NC接点、水平線・垂直線、通常・SET・RESETコイル、NOT、立り・立りエッジ、ボックス関数 | +| **②** | 機能と現在のショートカット | 各機能に現在割り当てられているキーを表示します。 | 
-| 構造編集 | セル挿入・削除、行挿入・削除 |+| **③** | 項目別の変更・リセット | 選択した機能のショートカットを変更するか既定値に戻します。 | 
 +| - | モニタリング | モニタリング切替 | 
 +| - | ラダー要素 | NO・NC接点、線・線、通常・SET・RESETコイル、NOT、立上り・立下りエッジ、ボックス関数 | 
 +| - | 構造編集 | セル挿入・削除、行の追加・削除 |
  
   - 対象項目の**変更**を選択します。   - 対象項目の**変更**を選択します。
行 92: 行 93:
  
 {{ :ja-jp_products:mpino_studio2:shortcut-conflict.svg?1000 |同じショートカットを割り当てたときの競合表示と実行優先順位 }} {{ :ja-jp_products:mpino_studio2:shortcut-conflict.svg?1000 |同じショートカットを割り当てたときの競合表示と実行優先順位 }}
 +
 +^ マーカー ^ 画面領域 ^ 動作 ^
 +| **①** | 入力したショートカット | 登録するキーまたはキーの組み合わせを表示します。 |
 +| **②** | 競合する機能の案内 | 同じショートカットが割り当てられた機能を表示します。先に登録された機能が実行されます。 |
 +| **③** | 確認・キャンセル | 入力したショートカットを確定するか変更を取り消します。 |
  
 各ラダーショートカットの動作は[[ja-jp_products:mpino_studio2:ladder_editing#ラダー編集のショートカット|Phase 3・ラダー編集のショートカット]]で確認できます。 各ラダーショートカットの動作は[[ja-jp_products:mpino_studio2:ladder_editing#ラダー編集のショートカット|Phase 3・ラダー編集のショートカット]]で確認できます。
行 101: 行 107:
 {{ :ja-jp_products:mpino_studio2:settings-ladder-marked.svg?1000 |シンボル表示・ラダー使用・二重コイル検査・自動入力ボックス・モニタリングポート }} {{ :ja-jp_products:mpino_studio2:settings-ladder-marked.svg?1000 |シンボル表示・ラダー使用・二重コイル検査・自動入力ボックス・モニタリングポート }}
  
-^ 項目 ^ 動作 ^ 適用範囲 ^ +^ マーカー ^ 項目 ^ 動作 ^ 適用範囲 ^ 
-| アドレス + シンボル表示 | シンボルとアドレスをラダーセルに表示します。 | このPC | +| **①** | アドレス + シンボル表示 | シンボルとアドレスをラダーセルに表示します。 | このPC | 
-| シンボルのみ表示 | シンボルがあればシンボルを表示し、なければアドレスを表示します。 | このPC | +| **②** | シンボルのみ表示 | シンボルがあればシンボルを表示し、なければアドレスを表示します。 | このPC | 
-| ラダーを使用 | チェックを外すとラダーロジックをビルドから除外し、Arduino Codeだけを使用します。 | このPC | +| **③** | ラダーを使用 | チェックを外すとラダーロジックをビルドから除外し、Arduino Codeだけを使用します。 | このPC | 
-| 二重コイル検査 | 同じアドレスを複数の出力コイルで使用するとビルドエラーを表示します。 | このPC | +| **④** | 二重コイル検査 | 同じアドレスを複数の出力コイルで使用するとビルドエラーを表示します。 | このPC | 
-| 接点作成時に自動入力ボックス | 接点やエッジを作成した直後にアドレス入力画面を開きます。 | このPC | +| **⑤** | 接点作成時に自動入力ボックス | 接点やエッジを作成した直後にアドレス入力画面を開きます。 | このPC | 
-| モニタリング使用ポート | ラダーモニタリングデータを送信するボードのシリアルチャンネルを選択します。 | 現在のプロジェクト |+| **⑥** | モニタリング使用ポート | ラダーモニタリングデータを送信するボードのシリアルチャンネルを選択します。 | 現在のプロジェクト |
  
 **ラダーを使用**のチェックを外しても、プロジェクトのラダータブは削除されません。ビルド時にラダー生成コードだけを除外します。 **ラダーを使用**のチェックを外しても、プロジェクトのラダータブは削除されません。ビルド時にラダー生成コードだけを除外します。
行 121: 行 127:
 {{ :ja-jp_products:mpino_studio2:settings-design-marked.svg?1000 |ラダーの色・セルサイズ・文字サイズ・ライン太さと保存 }} {{ :ja-jp_products:mpino_studio2:settings-design-marked.svg?1000 |ラダーの色・セルサイズ・文字サイズ・ライン太さと保存 }}
  
-{{ :ja-jp_products:mpino_studio2:ladder-design-before-after.svg?1000 |ラダーデザインの保存前保存後の比較 }}+^ マーカー ^ 色 ^ 現在適用される部分 ^ 
 +| **①** | セルの色 | ラダーセルの背景 | 
 +| **②** | セル選択の色 | 選択したラダーセル | 
 +| **③** | ライン色 | 接点・接続線・コイル | 
 +| **④** | テキスト色 | アドレスボックス関数の文字列 | 
 +| **⑤** | シンボルの色 | **今後の機能**と表示され、現在のラダーには適用されません。 | 
 +| **⑥** | モニタリングの色 | **今後の機能**と表示され、現在のラダーには適用されません。 |
  
-色 現在適用される部分 +マーカー 項目 ^ デフォルト ^ 入力範囲 
-セルの色 ラダーセルの背景 +**⑦** 幅 | 100px | 100~240px 
-セル選択の色 選択したラダーセル +**⑧** 高さ | 60px | 40~120px 
-ライン色 接点・接続線・コイル | +**⑨** 横セ数 | 12 | 4~32 
-| テキストの色 アドレスとボックス関数の文字列 +| **⑩** | テキストサイズ 13px | 9~24px 
-| シンボルの色 | **今後の機能**と表示現在のラダーは適用されせん。 | +| **** | ライン太さ | 2 | 1~40.5単位 | 
-| モニタリングの色 | **今後の機能**と表示され、現在ラダーに適用されせん。 |+| **⑫** | 工場出荷時戻す | - | 入力値を既定状態に戻し。 | 
 +| **** | 保存 | - | 入力したデザインをこPCの選択中のテに適用。 |
  
-^ 項目 ^ デフォルト ^ 入力範囲 ^ +{{ :ja-jp_products:mpino_studio2:ladder-design-before-after.svg?1000 |ラダーデザインの保存前と保存後の比較 }}
-| 幅 | 100px | 100~240px | +
-| 高さ | 60px | 40~120px | +
-| 横セル数 | 12 | 4~32 | +
-| テキストサイズ | 13px | 9~24px | +
-| ライン太さ | 2 | 1~4、0.5単位 |+
  
 色は''#RRGGBB''形式で入力します。数値が範囲外の場合や色の形式が正しくない場合は**保存**できません。 色は''#RRGGBB''形式で入力します。数値が範囲外の場合や色の形式が正しくない場合は**保存**できません。
行 148: 行 156:
 {{ :ja-jp_products:mpino_studio2:menu-edit-view-marked.svg?1000 |編集メニューと表示メニュー }} {{ :ja-jp_products:mpino_studio2:menu-edit-view-marked.svg?1000 |編集メニューと表示メニュー }}
  
-^ 編集項目 ^ 既定のショートカット ^ 動作 ^ +^ マーカー ^ 編集項目 ^ 既定のショートカット ^ 動作 ^ 
-| 元に戻す | ''Ctrl + Z'' | 直前のラダー編集を1段階戻します。 | +| **①** | 元に戻す | ''Ctrl + Z'' | 直前のラダー編集を1段階戻します。 | 
-| 切り取り | ''Ctrl + X'' | 選択したラダーセルをコピーして元の位置を空にします。 | +| **②** | 切り取り | ''Ctrl + X'' | 選択したラダーセルをコピーして元の位置を空にします。 | 
-| コピー | ''Ctrl + C'' | 選択したラダーセルをコピーします。 | +| **③** | コピー | ''Ctrl + C'' | 選択したラダーセルをコピーします。 | 
-| 貼り付け | ''Ctrl + V'' | コピーしたセルを現在の選択位置へ貼り付けます。 | +| **④** | 貼り付け | ''Ctrl + V'' | コピーしたセルを現在の選択位置へ貼り付けます。 | 
-| 削除 | ''Delete'' | 選択したラダーセルを空にします。 |+| **⑤** | 削除 | ''Delete'' | 選択したラダーセルを空にします。 |
  
-^ 表示項目 ^ 既定のショートカット ^ 動作 ^ +^ マーカー ^ 表示項目 ^ 既定のショートカット ^ 動作 ^ 
-| サイドバーの切り替え | ''Ctrl + B'' | 左側のサイドバーを開閉します。 | +| **⑥** | サイドバーの切り替え | ''Ctrl + B'' | 左側のサイドバーを開閉します。 | 
-| パネルの切り替え | ''Ctrl + J'' | エディタ下部のパネルを開閉します。 | +| **⑦** | パネルの切り替え | ''Ctrl + J'' | エディタ下部のパネルを開閉します。 | 
-| モニタリングの切り替え | ''Ctrl + M'' | ラダーモニタリングを開始・終了します。 |+| **⑧** | モニタリングの切り替え | ''Ctrl + M'' | ラダーモニタリングを開始・終了します。 |
  
 上部の**編集**メニューにある切り取り・コピー・貼り付け・削除はラダータブで使用します。Arduino Codeのテキスト編集では、コードエディタにフォーカスを置いて同じショートカットを使用します。 上部の**編集**メニューにある切り取り・コピー・貼り付け・削除はラダータブで使用します。Arduino Codeのテキスト編集では、コードエディタにフォーカスを置いて同じショートカットを使用します。
行 172: 行 180:
 {{ :ja-jp_products:mpino_studio2:menu-run-marked.svg?1000 |実行メニューのビルド・書き込み・通信・メモリ書き込み }} {{ :ja-jp_products:mpino_studio2:menu-run-marked.svg?1000 |実行メニューのビルド・書き込み・通信・メモリ書き込み }}
  
-^ 項目 ^ 既定のショートカット ^ 動作 ^ +^ マーカー ^ 項目 ^ 既定のショートカット ^ 動作 ^ 
-| ビルド | ''Ctrl + R'' | 現在の編集内容を変換してコンパイルします。 | +| **①** | ビルド | ''Ctrl + R'' | 現在の編集内容を変換してコンパイルします。 | 
-| アップロード | ''Ctrl + U'' | 現在の内容をビルドし、選択したポートから書き込みます。 | +| **②** | アップロード | ''Ctrl + U'' | 現在の内容をビルドし、選択したポートから書き込みます。 | 
-| アップロードのキャンセル | - | 実行中の書き込みを中止します。 | +| **③** | アップロードのキャンセル | - | 実行中の書き込みを中止します。 | 
-| 通信 | - | ボードのシリアル通信チャンネルを設定します。 | +| **④** | 通信 | - | ボードのシリアル通信チャンネルを設定します。 | 
-| メモリ書き込みリスト | - | 実行中のボードのメモリ値を確認・変更します。 |+| **⑤** | メモリ書き込みリスト | - | 実行中のボードのメモリ値を確認・変更します。 |
  
 ビルド・ポート選択・書き込みは[[ja-jp_products:mpino_studio2:first_project#プロジェクトをビルドする|Phase 1・プロジェクトをビルドする]]で確認できます。 ビルド・ポート選択・書き込みは[[ja-jp_products:mpino_studio2:first_project#プロジェクトをビルドする|Phase 1・プロジェクトをビルドする]]で確認できます。
行 187: 行 195:
 {{ :ja-jp_products:mpino_studio2:communication-settings-marked.svg?1000 |通信チャンネル・プロトコル・スレーブID・通信条件 }} {{ :ja-jp_products:mpino_studio2:communication-settings-marked.svg?1000 |通信チャンネル・プロトコル・スレーブID・通信条件 }}
  
-^ 項目 ^ 設定内容 ^ +^ マーカー ^ 項目 ^ 設定内容 ^ 
-| チャンネル | ボードが提供する''Serial1''・''Serial2''・''Serial3''通信チャンネル | +| **①** | チャンネル | ボードが提供する''Serial1''・''Serial2''・''Serial3''通信チャンネル | 
-| プロトコル | なし・Modbus RTU スレーブ(Modbus RTU Slave)・LS産電 Cnet スレーブ | +| **②** | プロトコル | なし・Modbus RTU スレーブ(Modbus RTU Slave)・LS産電 Cnet スレーブ | 
-| スレーブ ID | 1~247 | +| **③** | スレーブ ID | 1~247 | 
-| 通信速度 | チャンネルで使用するbaud | +| **④** | 通信速度 | チャンネルで使用するbaud | 
-| データビット | 5・6・7・8 | +| **⑤** | データビット | 5・6・7・8 | 
-| ストップビット | 1・2 | +| **⑥** | ストップビット | 1・2 | 
-| パリティ | なし・偶数・奇数 |+| **⑦** | パリティ | なし・偶数・奇数 |
  
 **なし**を選択すると、そのチャンネルの通信設定を使用しません。**Modbus RTU スレーブ**または**LS産電 Cnet スレーブ**を選択すると、スレーブIDと通信条件を設定できます。デフォルトはスレーブID 1、115200bps、データビット8、ストップビット1、パリティなしです。 **なし**を選択すると、そのチャンネルの通信設定を使用しません。**Modbus RTU スレーブ**または**LS産電 Cnet スレーブ**を選択すると、スレーブIDと通信条件を設定できます。デフォルトはスレーブID 1、115200bps、データビット8、ストップビット1、パリティなしです。
行 210: 行 218:
 {{ :ja-jp_products:mpino_studio2:memory-write-list-marked.svg?1000 |アドレス入力・現在値・書き込む値・行の書き込み・全て書き込み }} {{ :ja-jp_products:mpino_studio2:memory-write-list-marked.svg?1000 |アドレス入力・現在値・書き込む値・行の書き込み・全て書き込み }}
  
-{{ :ja-jp_products:mpino_studio2:memory-write-workflow.svg?1000 |アドレスと値を入力してボドへ書き込み、現在値を確認する順序 }} +^ マカー ^ 画面領域・機能 ^ 動作 ^ 
- +| **①** | モニタリング接続 | 最初にラダーモニタリング接続し、現在の接続状態を確認します。 | 
-  - ラダーモニタリング接続します。 +| **②** | アドレス・値・書き込み | メモリアドレスと値を入力し**書き込み**または''Enter''でボー書き込みます。 | 
-  - 上部の入力行にメモリアドレスと書き込む値を入力します。 +**③** | インポート・エクスポート・クリアすべて書き込み | 一覧の読込み・保存・クリア、または値がある全上から順書き込みを行います。 | 
-  - **書き込み**または''Enter''を押します。 +| **④** | 行ごとの書き込み・削除 選択した行だけを書き込むか、ボードの値を変一覧から削除します。 | 
-  - 登録したアレスと現在値が一覧に表示されることを確認します。 +| **⑤** | 現在値・書き込む値 | 登録したアドレスの現在値と書き込む値を確認します。 |
- +
-^ 項目 ^ 動作 ^ +
-| 取り込み | ファイルのメモリ書き込みリストで現在の一覧を置き換えます。 | +
-書き出し 現在の一覧をファルへ保存します。 | +
-クリア | 確認後、登録された行をすべて削除します。 | +
-| 全て書き込み | 値が入力された上から順書き込みます。 | +
-| 行の書き込み | その行だけをボードへ書き込みます。 | +
-| 行の削除 | ボードの値を変更せ、その行だけを一覧から削除します。 |+
  
 同じアドレスを複数回登録できません。アドレスが現在のボードのメモリ範囲外、または入力形式が正しくない行は書き込めません。**全て書き込み**は値が空の行を飛ばし、エラーが発生した行で停止します。 同じアドレスを複数回登録できません。アドレスが現在のボードのメモリ範囲外、または入力形式が正しくない行は書き込めません。**全て書き込み**は値が空の行を飛ばし、エラーが発生した行で停止します。
行 239: 行 239:
 {{ :ja-jp_products:mpino_studio2:menu-settings-marked.svg?1000 |設定メニューの6項目 }} {{ :ja-jp_products:mpino_studio2:menu-settings-marked.svg?1000 |設定メニューの6項目 }}
  
-^ 項目 ^ 既定のショートカット ^ 保存範囲 ^ 説明 ^ +^ マーカー ^ 項目 ^ 既定のショートカット ^ 保存範囲 ^ 説明 ^ 
-| メモリ領域設定 | ''Ctrl + Shift + M'' | 現在のプロジェクト | P・M・D・C・T・Rメモリ数を設定します。 | +| **①** | メモリ領域設定 | ''Ctrl + Shift + M'' | 現在のプロジェクト | P・M・D・C・T・Rメモリ数を設定します。 | 
-| ラダー設計設定 | ''Ctrl + Shift + D'' | このPC | ラダーデザイン環境設定を開きます。 | +| **②** | ラダー設計設定 | ''Ctrl + Shift + D'' | このPC | ラダーデザイン環境設定を開きます。 | 
-| ラダーピンマップ設定 | ''Ctrl + Shift + P'' | 現在のプロジェクト | ボードピンとラダーアドレスのマッピングを編集します。 | +| **③** | ラダーピンマップ設定 | ''Ctrl + Shift + P'' | 現在のプロジェクト | ボードピンとラダーアドレスのマッピングを編集します。 | 
-| ボード変更 | - | 現在のプロジェクト | 現在のプロジェクトで使用するボードを変更します。 | +| **④** | ボード変更 | - | 現在のプロジェクト | 現在のプロジェクトで使用するボードを変更します。 | 
-| 使用したメモリ | ''Ctrl + Shift + L'' | 参照機能 | プロジェクトで使用しているメモリアドレスと位置を確認します。 | +| **⑤** | 使用したメモリ | ''Ctrl + Shift + L'' | 参照機能 | プロジェクトで使用しているメモリアドレスと位置を確認します。 | 
-| EEPROM 停電保持 | ''Ctrl + Shift + E'' | 現在のプロジェクト | 電源を切った後も保持するメモリ領域を設定します。 |+| **⑥** | EEPROM 停電保持 | ''Ctrl + Shift + E'' | 現在のプロジェクト | 電源を切った後も保持するメモリ領域を設定します。 |
  
 メモリ領域設定と使用したメモリは[[ja-jp_products:mpino_studio2:memory#メモリ領域|Phase 2・メモリ領域]]で確認できます。ラダー設計設定はこのページの[[#ラダーデザイン|ラダーデザイン]]を確認してください。 メモリ領域設定と使用したメモリは[[ja-jp_products:mpino_studio2:memory#メモリ領域|Phase 2・メモリ領域]]で確認できます。ラダー設計設定はこのページの[[#ラダーデザイン|ラダーデザイン]]を確認してください。
行 255: 行 255:
 {{ :ja-jp_products:mpino_studio2:board-change-marked.svg?1000 |現在のボードと変更先ボードを選択する画面 }} {{ :ja-jp_products:mpino_studio2:board-change-marked.svg?1000 |現在のボードと変更先ボードを選択する画面 }}
  
-{{ :ja-jp_products:mpino_studio2:board-change-checklist.svg?1000 |変更後にピ割当メモリ・通信確認する順序 }}+^ マーカー ^ 画面領域 ^ 動作 ^ 
 +**①** | 製品シリズ | 変更先ボードの製品シリーズを選択します。 | 
 +| **②** | ボード選択 | 現在のプロジェクトで使用するボードとオプショ構成を選択します。 | 
 +| **③** | 選択キャンセル | 選択したボード適用するか、変更せずに画面を閉じます。 |
  
 ボードごとにピンマップ・メモリ数・通信チャンネルが異なる場合があります。ボードを変更した後は、**メモリ領域設定・ラダーピンマップ設定・通信・モニタリング使用ポート**を順に確認してください。 ボードごとにピンマップ・メモリ数・通信チャンネルが異なる場合があります。ボードを変更した後は、**メモリ領域設定・ラダーピンマップ設定・通信・モニタリング使用ポート**を順に確認してください。
行 267: 行 270:
 {{ :ja-jp_products:mpino_studio2:ladder-pinmap-marked.svg?1000 |LD・名前・ピン番号・方向と機能・使用・説明の各列 }} {{ :ja-jp_products:mpino_studio2:ladder-pinmap-marked.svg?1000 |LD・名前・ピン番号・方向と機能・使用・説明の各列 }}
  
-^ 列 ^ 意味 ^ 編集 ^ +^ マーカー ^ 列 ^ 意味 ^ 編集 ^ 
-| LD | ラダーで使用するP・M・D・C・Rアドレス | 可能 | +| **①** | LD | ラダーで使用するP・M・D・C・Rアドレス | 可能 | 
-| 名前 | ピンを区別する名前 | 可能 | +| **②** | 名前 | ピンを区別する名前 | 可能 | 
-| ピン番号 | Arduino Codeで使用するピン番号 | 読み取り専用 | +| **③** | ピン番号 | Arduino Codeで使用するピン番号 | 読み取り専用 | 
-| 方向/機能 | 入力・出力・アナログなどのピン機能 | 読み取り専用 | +| **④** | 方向/機能 | 入力・出力・アナログなどのピン機能 | 読み取り専用 | 
-| 使用 | 現在のプロジェクトでそのピンマッピングを使用するか選択 | 可能 | +| **⑤** | 使用 | 現在のプロジェクトでそのピンマッピングを使用するか選択 | 可能 | 
-| 説明 | ピンの用途 | 可能 |+| **⑥** | 説明 | ピンの用途 | 可能 |
  
 **使用**を外したピンはラダー入出力コードの生成対象から除外されます。使用しないピンのLDアドレスをラダーから参照するとビルドできません。 **使用**を外したピンはラダー入出力コードの生成対象から除外されます。使用しないピンのLDアドレスをラダーから参照するとビルドできません。
行 289: 行 292:
 {{ :ja-jp_products:mpino_studio2:eeprom-retain-marked.svg?1000 |保存オプション・電源検出ピン・メモリ範囲・EEPROMアドレス・使用量 }} {{ :ja-jp_products:mpino_studio2:eeprom-retain-marked.svg?1000 |保存オプション・電源検出ピン・メモリ範囲・EEPROMアドレス・使用量 }}
  
-{{ :ja-jp_products:mpino_studio2:eeprom-retain-memory-model.svg?1000 |値変更時保存停電検出時保存のメモリ構造 }}+^ マーカー ^ 画面領域 ^ 設定内容 ^ 
 +**①** | 保存オプション | オプション1はM・D・Cの値変更時保存し、オプション2は停電検出時にM・D・C・Tを保存します。両方を使用できます。 | 
 +| **②** | 電源検出ピン・検出時間 | オプション2で使用する入力ピンと検出時間を設定します。 | 
 +| **③** | 保持範囲・EEPROMアドレス | 各領域開始・終了アドレスとEEPROM開始アドレスを入力します。 | 
 +| **④** | EEPROM使用量 | 設定した使用量と残り容量を確認します。 | 
 +| **⑤** | 保存・キャンセル | 設定を現在のプロジェクトへ反映するか、変更せずに画面を閉じます。 |
  
-^ オプション ^ 保存時点 ^ 使用できるメモリ ^ 追加設定 ^ +{{ :ja-jp_products:mpino_studio2:eeprom-retain-memory-model.svg?1000 |値変更時保存と停電検出時保存のメモリ構造 }}
-| オプション1 | 値変更時 | M・D・C | なし | +
-| オプション2 | 停電検出時 | M・D・C・T | 電源検出ピン・検出時間 |+
  
 オプション1とオプション2は個別に選択し、同時に使用することもできます。オプション2には**電源検出ピン**と保持するメモリ領域が必要です。 オプション1とオプション2は個別に選択し、同時に使用することもできます。オプション2には**電源検出ピン**と保持するメモリ領域が必要です。
行 314: 行 320:
  
 {{ :ja-jp_products:mpino_studio2:menu-help-marked.svg?1000 |バグ報告・改善要望・アップデート確認・バージョン情報 }} {{ :ja-jp_products:mpino_studio2:menu-help-marked.svg?1000 |バグ報告・改善要望・アップデート確認・バージョン情報 }}
 +
 +^ マーカー ^ 項目 ^ 動作 ^
 +| **①** | バグ報告 | 問題の説明と診断情報を送信します。 |
 +| **②** | 改善を要望 | 必要な機能や改善内容を送信します。 |
 +| **③** | アップデートを確認 | インストールできる新しいアップデートがあるか確認します。 |
 +| **④** | バージョン情報 | プログラム情報を表示します。 |
  
 {{ :ja-jp_products:mpino_studio2:bug-report-marked.svg?1000 |バグの説明・診断情報・任意添付項目 }} {{ :ja-jp_products:mpino_studio2:bug-report-marked.svg?1000 |バグの説明・診断情報・任意添付項目 }}
  
-項目 ^ 動作 ^ +マーカー ^ 画面領域 ^ 動作 ^ 
-バグ報告 | 問題の説明と診断情報送信します。 | +**①** | 問題の説明 | 発生した問題再現方法入力します。 | 
-改善を要望 必要な機能や改善内容を送信します。 | +**②** 基本診断情報 | アプリケーションのバージョン、OS、ログの添付内容を確認します。 | 
-アッデートを確認 | インストールきる新しいアップデートがあるか確認します。 | +**③** | 任意の添付項目 | 現在のロジェク、画面キャプチャ、連絡先任意添付します。 | 
-バージョ情報 プログラム情報を表示します。 |+**④** | 送信・キャセル | 報送信するか画面を閉じます。 |
  
 **バグ報告**には、プログラムのバージョン・OS・ログを含む基本診断情報が常に添付されます。現在のプロジェクト・画面キャプチャ・連絡先は選択して添付できます。 **バグ報告**には、プログラムのバージョン・OS・ログを含む基本診断情報が常に添付されます。現在のプロジェクト・画面キャプチャ・連絡先は選択して添付できます。
行 374: 行 386:
   * [[ja-jp_products:mpino_studio2:code_editor|Phase 5・Arduino Codeの編集]] — コード編集とファイル管理   * [[ja-jp_products:mpino_studio2:code_editor|Phase 5・Arduino Codeの編集]] — コード編集とファイル管理
   * [[ja-jp_products:mpino_studio2:monitoring|Phase 6・シリアル・ラダーモニタリング]] — モニタリング接続とポートの使用関係   * [[ja-jp_products:mpino_studio2:monitoring|Phase 6・シリアル・ラダーモニタリング]] — モニタリング接続とポートの使用関係
 +  * [[ja-jp_products:mpino_studio2:activity_bar|Phase 8・アクティビティバーとサイドパネル]] — エクスプローラー、ラダー設定、ライブラリ、シンボル
   * [[ja-jp_products:mpino_studio2|MPINO STUDIO 2ユーザーマニュアル]]   * [[ja-jp_products:mpino_studio2|MPINO STUDIO 2ユーザーマニュアル]]
  
-[[ja-jp_products:mpino_studio2:monitoring|← Phase 6・シリアル・ラダーモニタリング]] | [[ja-jp_products:mpino_studio2|MPINO STUDIO 2ユーザーマニュアルに戻る]]+[[ja-jp_products:mpino_studio2:monitoring|← Phase 6・シリアル・ラダーモニタリング]] | [[ja-jp_products:mpino_studio2:activity_bar|Phase 8・アクティビティバーとサイドパネル →]] | [[ja-jp_products:mpino_studio2|MPINO STUDIO 2ユーザーマニュアルに戻る]]
  
ja-jp_products/mpino_studio2/menus_settings.1789092540.txt.gz · 最終更新: by 127.0.0.1

Donate Powered by PHP Valid HTML5 Valid CSS Driven by DokuWiki