products:mpino_studio2:menus_settings
차이
문서의 선택한 두 판 사이의 차이를 보여줍니다.
| 양쪽 이전 판이전 판다음 판 | 이전 판 | ||
| products:mpino_studio2:menus_settings [2026/09/11 15:32] – 바깥 편집 127.0.0.1 | products:mpino_studio2:menus_settings [2026/10/25 11:33] (현재) – 바깥 편집 127.0.0.1 | ||
|---|---|---|---|
| 줄 7: | 줄 7: | ||
| ===== 1. 메뉴바 ===== | ===== 1. 메뉴바 ===== | ||
| - | 메뉴바에는 **파일ㆍ편집ㆍ보기ㆍ실행ㆍ설정ㆍ도움말** 메뉴가 있습니다. 프로젝트 파일을 관리할 때는 **파일**, 화면을 편집할 때는 **편집**, 화면 영역을 열고 닫을 때는 **보기** 메뉴를 사용합니다. | + | 메뉴바에는 **파일ㆍ편집ㆍ보기ㆍ실행ㆍ설정ㆍ도움말** 메뉴가 있습니다. 프로젝트 파일을 관리할 때는 **파일**, 화면을 편집할 때는 **편집**, 화면 영역을 열고 닫을 때는 **보기** 메뉴를 사용해주시기 바랍니다. |
| {{ : | {{ : | ||
| 줄 14: | 줄 14: | ||
| | **①** | 파일 | 프로젝트 생성ㆍ열기ㆍ저장ㆍ인쇄, | | **①** | 파일 | 프로젝트 생성ㆍ열기ㆍ저장ㆍ인쇄, | ||
| | **②** | 편집 | 래더 셀 실행 취소ㆍ잘라내기ㆍ복사ㆍ붙여넣기ㆍ삭제 | | | **②** | 편집 | 래더 셀 실행 취소ㆍ잘라내기ㆍ복사ㆍ붙여넣기ㆍ삭제 | | ||
| - | | **③** | 보기 | 사이드바ㆍ하단 패널ㆍ래더 모니터링 표시 전환 | | + | | **③** | 보기 | 사이드 |
| | **④** | 실행 | 빌드ㆍ업로드ㆍ통신 설정ㆍ메모리 쓰기 | | | **④** | 실행 | 빌드ㆍ업로드ㆍ통신 설정ㆍ메모리 쓰기 | | ||
| | **⑤** | 설정 | 메모리 영역ㆍ래더 디자인ㆍ핀맵ㆍ보드ㆍEEPROM 설정 | | | **⑤** | 설정 | 메모리 영역ㆍ래더 디자인ㆍ핀맵ㆍ보드ㆍEEPROM 설정 | | ||
| 줄 29: | 줄 29: | ||
| ^ 마킹 ^ 항목 ^ 기본 단축키 ^ 동작 ^ | ^ 마킹 ^ 항목 ^ 기본 단축키 ^ 동작 ^ | ||
| | **①** | 새로 만들기 | '' | | **①** | 새로 만들기 | '' | ||
| - | | **①** | 열기 | '' | + | | **②** | 열기 | '' |
| - | | **②** | 저장 | '' | + | | **③** | 저장 | '' |
| - | | **②** | 다른 이름으로 저장 | '' | + | | **④** | 다른 이름으로 저장 | '' |
| - | | **③** | 인쇄 | '' | + | | **⑤** | 인쇄 | '' |
| - | | **④** | 환경설정 | - | 설정 창의 **일반** 탭을 엽니다. | | + | | **⑥** | 환경설정 | - | 설정 창의 **일반** 탭을 엽니다. | |
| - | | **⑤** | 끝내기 | - | MPINO Studio 2를 종료합니다. | | + | | **⑦** | 끝내기 | - | MPINO Studio 2를 종료합니다. | |
| + | |||
| + | **열기**는 MPINO Studio 2에서 저장한 '' | ||
| 저장하지 않은 변경사항이 있으면 **새로 만들기**와 **열기**를 실행하기 전에 변경사항을 버릴지 확인합니다. 확인 창이나 이어서 열린 파일ㆍ보드 선택창을 취소하면 현재 프로젝트를 유지합니다. | 저장하지 않은 변경사항이 있으면 **새로 만들기**와 **열기**를 실행하기 전에 변경사항을 버릴지 확인합니다. 확인 창이나 이어서 열린 파일ㆍ보드 선택창을 취소하면 현재 프로젝트를 유지합니다. | ||
| 줄 54: | 줄 56: | ||
| ==== 일반 ==== | ==== 일반 ==== | ||
| - | **일반** 탭에서 사용자 라이브러리 폴더ㆍ플랫폼 폴더ㆍ프로그램 언어ㆍ오류 리포트 전송 여부를 설정합니다. | + | **일반** 탭에서 사용자 라이브러리 폴더ㆍ플랫폼 폴더ㆍ프로그램 언어ㆍ오류 리포트 전송 여부를 설정해주시기 바랍니다. |
| {{ : | {{ : | ||
| 줄 82: | 줄 84: | ||
| | - | 구조 편집 | 셀 삽입ㆍ삭제, | | - | 구조 편집 | 셀 삽입ㆍ삭제, | ||
| - | - 변경할 기능의 **변경**을 선택합니다. | + | - 변경할 기능의 **변경**을 선택해주시기 바랍니다. |
| - 사용할 키 또는 키 조합을 누릅니다. | - 사용할 키 또는 키 조합을 누릅니다. | ||
| - '' | - '' | ||
| - | 한 항목만 기본 단축키로 되돌리려면 해당 행의 **초기화**를 선택합니다. 변경한 단축키를 모두 되돌리려면 **모두 default로**를 선택합니다. | + | 한 항목만 기본 단축키로 되돌리려면 해당 행의 **초기화**를 선택해주시기 바랍니다. 변경한 단축키를 모두 되돌리려면 **모두 default로**를 선택해주시기 바랍니다. |
| 같은 단축키가 여러 기능에 지정되면 **충돌하는 단축키**가 표시됩니다. 충돌한 상태에서도 변경값은 저장되며, | 같은 단축키가 여러 기능에 지정되면 **충돌하는 단축키**가 표시됩니다. 충돌한 상태에서도 변경값은 저장되며, | ||
| 줄 101: | 줄 103: | ||
| ==== 래더 설정 ==== | ==== 래더 설정 ==== | ||
| - | **래더 설정** 탭에서 래더 셀의 표시 방법과 빌드 검사, 접점 입력창, 래더 모니터링 포트를 설정합니다. | + | **래더 설정** 탭에서 래더 셀의 표시 방법과 빌드 검사, 접점 입력창, 래더 모니터링 포트를 설정해주시기 바랍니다. |
| {{ : | {{ : | ||
| 줄 107: | 줄 109: | ||
| ^ 마킹 ^ 항목 ^ 동작 ^ 적용 범위 ^ | ^ 마킹 ^ 항목 ^ 동작 ^ 적용 범위 ^ | ||
| | **①** | 주소 + 심볼 보기 | 심볼과 주소를 래더 셀에 함께 표시합니다. | 현재 PC | | | **①** | 주소 + 심볼 보기 | 심볼과 주소를 래더 셀에 함께 표시합니다. | 현재 PC | | ||
| - | | **①** | 심볼만 보기 | 심볼이 있으면 심볼을 표시하고, | + | | **②** | 심볼만 보기 | 심볼이 있으면 심볼을 표시하고, |
| - | | **②** | 래더 사용 | 체크를 해제하면 래더로직을 빌드에서 제외하고 Arduino Code만 사용합니다. | 현재 PC | | + | | **③** | 래더 사용 | 체크를 해제하면 래더로직을 빌드에서 제외하고 Arduino Code만 사용합니다. | 현재 PC | |
| - | | **③** | 이중코일 검사 | 같은 주소를 두 개 이상의 출력 코일에서 사용하면 빌드 오류로 표시합니다. | 현재 PC | | + | | **④** | 이중코일 검사 | 같은 주소를 두 개 이상의 출력 코일에서 사용하면 빌드 오류로 표시합니다. | 현재 PC | |
| - | | **④** | 접점 생성시 자동 입력박스 | 접점이나 엣지를 생성한 직후 주소 입력창을 엽니다. | 현재 PC | | + | | **⑤** | 접점 생성시 자동 입력박스 | 접점이나 엣지를 생성한 직후 주소 입력창을 엽니다. | 현재 PC | |
| - | | **⑤** | 모니터링 사용 포트 | 래더 모니터링 데이터를 송신할 보드 시리얼 채널을 선택합니다. | 현재 프로젝트 | | + | | **⑥** | 모니터링 사용 포트 | 래더 모니터링 데이터를 송신할 보드 시리얼 채널을 선택합니다. | 현재 프로젝트 | |
| **래더 사용**을 해제해도 프로젝트의 래더 탭은 삭제되지 않습니다. 빌드할 때 래더 생성 코드만 제외됩니다. | **래더 사용**을 해제해도 프로젝트의 래더 탭은 삭제되지 않습니다. 빌드할 때 래더 생성 코드만 제외됩니다. | ||
| - | **모니터링 사용 포트**에는 현재 보드에서 사용할 수 있는 채널만 표시됩니다. 변경한 포트는 다음 빌드ㆍ업로드부터 적용되며, | + | **모니터링 사용 포트**에는 현재 보드에서 사용할 수 있는 채널만 표시됩니다. 변경한 포트는 다음 빌드ㆍ업로드부터 적용되며, |
| 래더 모니터링 연결과 포트 충돌은 [[products: | 래더 모니터링 연결과 포트 충돌은 [[products: | ||
| 줄 121: | 줄 123: | ||
| ==== 래더 디자인 ==== | ==== 래더 디자인 ==== | ||
| - | **래더 디자인** 탭에서 래더 셀의 색상ㆍ크기ㆍ가로 셀 수ㆍ글자 크기ㆍ선 두께를 설정합니다. 설정값은 현재 PC의 현재 테마에 적용됩니다. | + | **래더 디자인** 탭에서 래더 셀의 색상ㆍ크기ㆍ가로 셀 수ㆍ글자 크기ㆍ선 두께를 설정해주시기 바랍니다. 설정값은 현재 PC의 현재 테마에 적용됩니다. |
| {{ : | {{ : | ||
| 줄 127: | 줄 129: | ||
| ^ 마킹 ^ 색상 ^ 현재 적용되는 부분 ^ | ^ 마킹 ^ 색상 ^ 현재 적용되는 부분 ^ | ||
| | **①** | 셀 색상 | 래더 셀의 배경 | | | **①** | 셀 색상 | 래더 셀의 배경 | | ||
| - | | **①** | 셀 선택 색상 | 선택한 래더 셀 | | + | | **②** | 셀 선택 색상 | 선택한 래더 셀 | |
| - | | **①** | 라인 색상 | 접점ㆍ연결선ㆍ코일 | | + | | **③** | 라인 색상 | 접점ㆍ연결선ㆍ코일 | |
| - | | **①** | 텍스트 색상 | 주소와 박스함수 문자열 | | + | | **④** | 텍스트 색상 | 주소와 박스함수 문자열 | |
| - | | **①** | 심볼 색상 | 화면에 **향후 기능**으로 표시되며 현재 래더에는 적용되지 않습니다. | | + | | **⑤** | 심볼 색상 | 화면에 **향후 기능**으로 표시되며 현재 래더에는 적용되지 않습니다. | |
| - | | **①** | 모니터링 색상 | 화면에 **향후 기능**으로 표시되며 현재 래더에는 적용되지 않습니다. | | + | | **⑥** | 모니터링 색상 | 화면에 **향후 기능**으로 표시되며 현재 래더에는 적용되지 않습니다. | |
| ^ 마킹 ^ 항목 ^ 기본값 ^ 입력 범위 ^ | ^ 마킹 ^ 항목 ^ 기본값 ^ 입력 범위 ^ | ||
| - | | **②** | 가로 | 100px | 100 ~ 240px | | + | | **⑦** | 가로 | 100px | 100 ~ 240px | |
| - | | **②** | 세로 | 60px | 40 ~ 120px | | + | | **⑧** | 세로 | 60px | 40 ~ 120px | |
| - | | **②** | 가로 셀 수 | 12 | 4 ~ 32 | | + | | **⑨** | 가로 셀 수 | 12 | 4 ~ 32 | |
| - | | **③** | 텍스트 크기 | 13px | 9 ~ 24px | | + | | **⑩** | 텍스트 크기 | 13px | 9 ~ 24px | |
| - | | **③** | 라인 두께 | 2 | 1 ~ 4, 0.5 단위 | | + | | **⑪** | 라인 두께 | 2 | 1 ~ 4, 0.5 단위 | |
| - | | **④** | 공장 초기화 | - | 입력값을 기본 상태로 되돌립니다. | | + | | **⑫** | 공장 초기화 | - | 입력값을 기본 상태로 되돌립니다. | |
| - | | **④** | 저장 | - | 입력한 디자인을 현재 PC의 선택한 테마에 적용합니다. | | + | | **⑬** | 저장 | - | 입력한 디자인을 현재 PC의 선택한 테마에 적용합니다. | |
| {{ : | {{ : | ||
| - | 색상은 ''# | + | 색상은 ''# |
| 입력칸을 비워 두면 해당 항목의 기본값을 사용합니다. **공장 초기화**는 입력값을 기본 상태로 되돌리며, | 입력칸을 비워 두면 해당 항목의 기본값을 사용합니다. **공장 초기화**는 입력값을 기본 상태로 되돌리며, | ||
| 줄 150: | 줄 152: | ||
| ===== 4. 편집ㆍ보기 메뉴 ===== | ===== 4. 편집ㆍ보기 메뉴 ===== | ||
| - | **편집** 메뉴는 래더 셀을 수정할 때 사용하고, | + | **편집** 메뉴는 래더 셀을 수정할 때 사용하고, |
| {{ : | {{ : | ||
| 줄 157: | 줄 159: | ||
| | **①** | 실행 취소 | '' | | **①** | 실행 취소 | '' | ||
| | **②** | 잘라내기 | '' | | **②** | 잘라내기 | '' | ||
| - | | **②** | 복사 | '' | + | | **③** | 복사 | '' |
| - | | **②** | 붙여넣기 | '' | + | | **④** | 붙여넣기 | '' |
| - | | **②** | 삭제 | '' | + | | **⑤** | 삭제 | '' |
| ^ 마킹 ^ 보기 항목 ^ 기본 단축키 ^ 동작 ^ | ^ 마킹 ^ 보기 항목 ^ 기본 단축키 ^ 동작 ^ | ||
| - | | **③** | 사이드바 토글 | '' | + | | **⑥** | 사이드바 토글 | '' |
| - | | **③** | 패널 토글 | '' | + | | **⑦** | 패널 토글 | '' |
| - | | **④** | 모니터링 토글 | '' | + | | **⑧** | 모니터링 토글 | '' |
| - | 상단 **편집** 메뉴의 잘라내기ㆍ복사ㆍ붙여넣기ㆍ삭제는 래더 탭에서 사용합니다. Arduino Code의 텍스트를 편집할 때는 코드 편집기 안에서 같은 단축키를 사용합니다. | + | 상단 **편집** 메뉴의 잘라내기ㆍ복사ㆍ붙여넣기ㆍ삭제는 래더 탭에서 사용합니다. Arduino Code의 텍스트를 편집할 때는 코드 편집기 안에서 같은 단축키를 사용해주시기 바랍니다. |
| 상단 **편집 → 실행 취소**는 활성 탭과 관계없이 최근 래더 편집을 되돌립니다. Arduino Code의 내용을 되돌리려면 코드 입력 영역에 포커스를 둔 상태에서 '' | 상단 **편집 → 실행 취소**는 활성 탭과 관계없이 최근 래더 편집을 되돌립니다. Arduino Code의 내용을 되돌리려면 코드 입력 영역에 포커스를 둔 상태에서 '' | ||
| 줄 180: | 줄 182: | ||
| ^ 마킹 ^ 항목 ^ 기본 단축키 ^ 동작 ^ | ^ 마킹 ^ 항목 ^ 기본 단축키 ^ 동작 ^ | ||
| | **①** | 빌드 | '' | | **①** | 빌드 | '' | ||
| - | | **①** | 업로드 | '' | + | | **②** | 업로드 | '' |
| - | | **②** | 업로드 취소 | - | 진행 중인 업로드를 중단합니다. | | + | | **③** | 업로드 취소 | - | 진행 중인 업로드를 중단합니다. | |
| - | | **③** | 통신 | - | 보드의 시리얼 통신 채널을 설정합니다. | | + | | **④** | 통신 | - | 보드의 시리얼 통신 채널을 설정합니다. | |
| - | | **④** | 메모리 쓰기 목록 | - | 실행 중인 보드의 메모리 값을 확인하고 변경합니다. | | + | | **⑤** | 메모리 쓰기 목록 | - | 실행 중인 보드의 메모리 값을 확인하고 변경합니다. | |
| 빌드ㆍ포트 선택ㆍ업로드 과정은 [[products: | 빌드ㆍ포트 선택ㆍ업로드 과정은 [[products: | ||
| 줄 198: | 줄 200: | ||
| | **③** | Slave ID | 1 ~ 247 | | | **③** | Slave ID | 1 ~ 247 | | ||
| | **④** | 통신속도 | 채널에서 사용할 baud | | | **④** | 통신속도 | 채널에서 사용할 baud | | ||
| - | | **④** | 데이터 비트 | 5ㆍ6ㆍ7ㆍ8 | | + | | **⑤** | 데이터 비트 | 5ㆍ6ㆍ7ㆍ8 | |
| - | | **④** | 정지 비트 | 1ㆍ2 | | + | | **⑥** | 정지 비트 | 1ㆍ2 | |
| - | | **④** | 패리티 | 없음ㆍ짝수ㆍ홀수 | | + | | **⑦** | 패리티 | 없음ㆍ짝수ㆍ홀수 | |
| **없음**을 선택하면 해당 채널의 통신 설정을 사용하지 않습니다. **Modbus RTU Slave** 또는 **LS산전 Cnet Slave**를 선택하면 Slave ID와 통신 조건을 설정할 수 있습니다. 기본값은 Slave ID 1, 115200bps, 데이터 비트 8, 정지 비트 1, 패리티 없음입니다. | **없음**을 선택하면 해당 채널의 통신 설정을 사용하지 않습니다. **Modbus RTU Slave** 또는 **LS산전 Cnet Slave**를 선택하면 Slave ID와 통신 조건을 설정할 수 있습니다. 기본값은 Slave ID 1, 115200bps, 데이터 비트 8, 정지 비트 1, 패리티 없음입니다. | ||
| 줄 206: | 줄 208: | ||
| **Modbus RTU Master**와 **Modbus TCP/IP**는 화면에 추후 지원 항목으로 표시되며 선택할 수 없습니다. | **Modbus RTU Master**와 **Modbus TCP/IP**는 화면에 추후 지원 항목으로 표시되며 선택할 수 없습니다. | ||
| - | 통신 설정은 선택 즉시 현재 프로젝트에 반영되며 다음 빌드ㆍ업로드부터 사용됩니다. 저장하지 않은 상태에서도 현재 편집 내용으로 빌드할 수 있지만, 프로젝트를 다시 열 때 설정을 유지하려면 '' | + | 통신 설정은 선택 즉시 현재 프로젝트에 반영되며 다음 빌드ㆍ업로드부터 사용됩니다. 저장하지 않은 상태에서도 현재 편집 내용으로 빌드할 수 있지만, 프로젝트를 다시 열 때 설정을 유지하려면 '' |
| - | 같은 채널을 Arduino Codeㆍ통신 설정ㆍ래더 모니터링에서 함께 사용하면 업로드하기 전에 충돌 안내가 표시됩니다. [[products: | + | 같은 채널을 Arduino Codeㆍ통신 설정ㆍ래더 모니터링에서 함께 사용하면 업로드하기 전에 충돌 안내가 표시됩니다. [[products: |
| ==== 메모리 쓰기 목록 ==== | ==== 메모리 쓰기 목록 ==== | ||
| 줄 225: | 줄 227: | ||
| 같은 주소를 두 번 등록할 수 없습니다. 주소가 현재 보드의 메모리 범위를 벗어나거나 입력 형식이 올바르지 않으면 해당 행을 쓸 수 없습니다. **전체 쓰기**는 값이 비어 있는 행을 건너뛰며, | 같은 주소를 두 번 등록할 수 없습니다. 주소가 현재 보드의 메모리 범위를 벗어나거나 입력 형식이 올바르지 않으면 해당 행을 쓸 수 없습니다. **전체 쓰기**는 값이 비어 있는 행을 건너뛰며, | ||
| - | 목록은 현재 프로젝트에 저장되는 자료입니다. 프로젝트를 다시 열 때 목록을 유지하려면 '' | + | 목록은 현재 프로젝트에 저장되는 자료입니다. 프로젝트를 다시 열 때 목록을 유지하려면 '' |
| - | > **메모리 쓰기 주의:** 메모리 값을 쓰면 실행 중인 래더로직의 조건과 출력 결과가 바로 바뀔 수 있습니다. 장비가 안전한 상태인지 | + | > **메모리 쓰기 주의:** 메모리 값을 쓰면 실행 중인 래더로직의 조건과 출력 결과가 바로 바뀔 수 있습니다. 장비가 안전한 상태인지, 대상 |
| 주소와 값의 데이터 형식은 [[products: | 주소와 값의 데이터 형식은 [[products: | ||
| 줄 258: | 줄 260: | ||
| | **③** | 선택ㆍ취소 | 선택한 보드를 적용하거나 변경하지 않고 창을 닫습니다. | | | **③** | 선택ㆍ취소 | 선택한 보드를 적용하거나 변경하지 않고 창을 닫습니다. | | ||
| - | 보드마다 핀맵ㆍ메모리 개수ㆍ통신 채널이 다를 수 있습니다. 보드를 변경한 뒤에는 **메모리 영역 설정ㆍ래더 핀맵 설정ㆍ통신ㆍ모니터링 사용 포트**를 차례로 확인하십시오. | + | 보드마다 핀맵ㆍ메모리 개수ㆍ통신 채널이 다를 수 있습니다. 보드를 변경한 뒤에는 **메모리 영역 설정ㆍ래더 핀맵 설정ㆍ통신ㆍ모니터링 사용 포트**를 차례로 확인해야 합니다. |
| - | 변경한 보드는 현재 프로젝트에 반영됩니다. 프로젝트 파일에 보존하려면 '' | + | 변경한 보드는 현재 프로젝트에 반영됩니다. 프로젝트 파일에 보존하려면 '' |
| ==== 래더 핀맵 설정 ==== | ==== 래더 핀맵 설정 ==== | ||
| - | **설정 → 래더 핀맵 설정**에서 보드 핀과 래더 주소의 연결 상태를 확인하고 수정합니다. | + | **설정 → 래더 핀맵 설정**에서 보드 핀과 래더 주소의 연결 상태를 확인하고 수정해주시기 바랍니다. |
| {{ : | {{ : | ||
| 줄 274: | 줄 276: | ||
| | **④** | 방향/ | | **④** | 방향/ | ||
| | **⑤** | 사용 | 현재 프로젝트에서 해당 핀 매핑을 사용할지 선택 | 수정 가능 | | | **⑤** | 사용 | 현재 프로젝트에서 해당 핀 매핑을 사용할지 선택 | 수정 가능 | | ||
| - | | **⑤** | 설명 | 핀의 용도에 대한 설명 | 수정 가능 | | + | | **⑥** | 설명 | 핀의 용도에 대한 설명 | 수정 가능 | |
| **사용**을 해제한 핀은 래더 입출력 코드 생성 대상에서 제외됩니다. 사용하지 않는 핀의 LD 주소를 래더에서 참조하면 빌드할 수 없습니다. | **사용**을 해제한 핀은 래더 입출력 코드 생성 대상에서 제외됩니다. 사용하지 않는 핀의 LD 주소를 래더에서 참조하면 빌드할 수 없습니다. | ||
| 줄 280: | 줄 282: | ||
| 같은 LD 주소나 Arduino 핀 번호를 중복해 사용할 수 없습니다. 입력한 주소가 핀 기능에 맞지 않으면 **확인** 버튼이 비활성화되고 오류가 표시됩니다. | 같은 LD 주소나 Arduino 핀 번호를 중복해 사용할 수 없습니다. 입력한 주소가 핀 기능에 맞지 않으면 **확인** 버튼이 비활성화되고 오류가 표시됩니다. | ||
| - | **확인**을 선택하면 변경내용이 현재 프로젝트에 반영됩니다. 프로젝트 파일에 보존하려면 '' | + | **확인**을 선택하면 변경내용이 현재 프로젝트에 반영됩니다. 프로젝트 파일에 보존하려면 '' |
| 핀 매핑의 메모리 주소와 아날로그 출력 사용 관계는 [[products: | 핀 매핑의 메모리 주소와 아날로그 출력 사용 관계는 [[products: | ||
| 줄 286: | 줄 288: | ||
| ==== EEPROM 정전유지 ==== | ==== EEPROM 정전유지 ==== | ||
| - | **설정 → EEPROM 정전유지**에서 전원이 꺼진 뒤에도 유지할 메모리 영역과 저장 시점을 설정합니다. | + | **설정 → EEPROM 정전유지**에서 전원이 꺼진 뒤에도 유지할 메모리 영역과 저장 시점을 설정해주시기 바랍니다. |
| {{ : | {{ : | ||
| 줄 301: | 줄 303: | ||
| 옵션1과 옵션2는 각각 선택하며 동시에 사용할 수도 있습니다. 옵션2를 사용하려면 **전원감지 핀**과 저장할 메모리 영역을 선택해야 합니다. | 옵션1과 옵션2는 각각 선택하며 동시에 사용할 수도 있습니다. 옵션2를 사용하려면 **전원감지 핀**과 저장할 메모리 영역을 선택해야 합니다. | ||
| - | 각 영역에서 유지할 시작ㆍ끝 주소와 EEPROM 시작 주소를 입력합니다. **EEPROM 자동세팅**을 선택하면 활성화된 영역을 겹치지 않도록 EEPROM 주소 '' | + | 각 영역에서 유지할 시작ㆍ끝 주소와 EEPROM 시작 주소를 입력해주시기 바랍니다. **EEPROM 자동세팅**을 선택하면 활성화된 영역을 겹치지 않도록 EEPROM 주소 '' |
| EEPROM 전체 용량은 4096바이트입니다. 마지막 8바이트는 내부 데이터에 사용하므로 메모리 유지 영역은 '' | EEPROM 전체 용량은 4096바이트입니다. 마지막 8바이트는 내부 데이터에 사용하므로 메모리 유지 영역은 '' | ||
| 줄 307: | 줄 309: | ||
| 메모리 범위가 현재 프로젝트의 영역 크기를 넘거나 EEPROM 주소가 서로 겹치거나 사용 가능한 용량을 초과하면 설정을 저장할 수 없습니다. | 메모리 범위가 현재 프로젝트의 영역 크기를 넘거나 EEPROM 주소가 서로 겹치거나 사용 가능한 용량을 초과하면 설정을 저장할 수 없습니다. | ||
| - | 설정 창의 **저장**은 변경내용을 현재 프로젝트에 반영합니다. 다음 빌드에는 바로 사용되며, | + | 설정 창의 **저장**은 변경내용을 현재 프로젝트에 반영합니다. 다음 빌드에는 바로 사용되며, |
| - | > **EEPROM 쓰기 주의:** EEPROM은 반복해서 기록할 수 있는 횟수에 제한이 있습니다. 옵션1은 값이 바뀔 때마다 저장하므로 빠르게 변하는 메모리를 유지 영역에 포함하지 마십시오. | + | > **EEPROM 쓰기 주의:** EEPROM은 반복해서 기록할 수 있는 횟수에 제한이 있습니다. 옵션1은 값이 바뀔 때마다 저장하므로 빠르게 변하는 메모리를 유지 영역에 포함해서는 안 됩니다. |
| - | 옵션2는 전원감지 핀이 다른 용도로 사용되는지 자동으로 검사하지 않습니다. 다른 입출력 용도와 겹치지 않는 핀을 선택하십시오. | + | 옵션2는 전원감지 핀이 다른 용도로 사용되는지 자동으로 검사하지 않습니다. 다른 입출력 용도와 겹치지 않는 핀을 선택해야 합니다. |
| ===== 7. 도움말 메뉴 ===== | ===== 7. 도움말 메뉴 ===== | ||
| 줄 339: | 줄 341: | ||
| 전송에 실패한 신고와 요청은 프로그램의 아웃박스에 보관되고 다시 전송됩니다. 첨부파일을 만들지 못해도 준비된 내용으로 전송을 계속합니다. | 전송에 실패한 신고와 요청은 프로그램의 아웃박스에 보관되고 다시 전송됩니다. 첨부파일을 만들지 못해도 준비된 내용으로 전송을 계속합니다. | ||
| - | **업데이트 확인**을 선택하면 업데이트 서버에 연결합니다. 최신 상태이면 안내 메시지가 표시되고, | + | **업데이트 확인**을 선택하면 업데이트 서버에 연결합니다. 최신 상태이면 안내 메시지가 표시되고, |
| **정보**를 선택하면 현재 프로그램 정보가 표시됩니다. | **정보**를 선택하면 현재 프로그램 정보가 표시됩니다. | ||
| 줄 367: | 줄 369: | ||
| ^ 증상 ^ 확인할 항목 ^ 조치 ^ | ^ 증상 ^ 확인할 항목 ^ 조치 ^ | ||
| - | | 변경한 환경설정이 보이지 않습니다. | 설정 탭과 적용 시점 | 래더 디자인은 **저장**을 선택하고, | + | | 변경한 환경설정이 보이지 않습니다. | 설정 탭과 적용 시점 | 래더 디자인은 **저장**을 선택하고, |
| - | | 단축키를 눌렀는데 다른 기능이 실행됩니다. | **충돌하는 단축키** 표시 | 충돌한 항목 중 하나를 다른 키로 변경하거나 초기화합니다. | | + | | 단축키를 눌렀는데 다른 기능이 실행됩니다. | **충돌하는 단축키** 표시 | 충돌한 항목 중 하나를 다른 키로 변경하거나 초기화해주시기 바랍니다. | |
| - | | 래더 디자인을 저장할 수 없습니다. | 색상 형식과 숫자 범위 | 색상을 ''# | + | | 래더 디자인을 저장할 수 없습니다. | 색상 형식과 숫자 범위 | 색상을 ''# |
| - | | 통신 설정이 보드 동작에 반영되지 않습니다. | 프로토콜ㆍ채널ㆍ빌드 상태 | 사용할 프로토콜을 선택하고 변경된 설정으로 다시 빌드ㆍ업로드합니다. | | + | | 통신 설정이 보드 동작에 반영되지 않습니다. | 프로토콜ㆍ채널ㆍ빌드 상태 | 사용할 프로토콜을 선택하고 변경된 설정으로 다시 빌드ㆍ업로드해주시기 바랍니다. | |
| - | | 메모리 쓰기 버튼이 비활성화됩니다. | 모니터링 연결ㆍ주소ㆍ값 | 래더 모니터링을 연결하고 주소와 값을 현재 보드의 범위에 맞게 수정합니다. | | + | | 메모리 쓰기 버튼이 비활성화됩니다. | 모니터링 연결ㆍ주소ㆍ값 | 래더 모니터링을 연결하고 주소와 값을 현재 보드의 범위에 맞게 수정해주시기 바랍니다. | |
| - | | 전체 쓰기가 중간에 멈춥니다. | 오류가 표시된 첫 번째 행 | 해당 행의 주소와 값을 수정한 뒤 다시 실행합니다. | | + | | 전체 쓰기가 중간에 멈춥니다. | 오류가 표시된 첫 번째 행 | 해당 행의 주소와 값을 수정한 뒤 다시 실행해주시기 바랍니다. | |
| - | | 보드 변경 후 핀 주소가 맞지 않습니다. | 선택한 보드와 래더 핀맵 | **설정 → 래더 핀맵 설정**에서 주소를 확인하고 다시 빌드합니다. | | + | | 보드 변경 후 핀 주소가 맞지 않습니다. | 선택한 보드와 래더 핀맵 | **설정 → 래더 핀맵 설정**에서 주소를 확인하고 다시 빌드해주시기 바랍니다. | |
| - | | EEPROM 정전유지를 저장할 수 없습니다. | 메모리 범위ㆍ주소 중복ㆍ용량ㆍ전원감지 핀 | 표시된 오류 항목을 수정하고 옵션2를 사용하면 전원감지 핀을 선택합니다. | | + | | EEPROM 정전유지를 저장할 수 없습니다. | 메모리 범위ㆍ주소 중복ㆍ용량ㆍ전원감지 핀 | 표시된 오류 항목을 수정하고 옵션2를 사용하면 전원감지 핀을 선택해야 |
| - | | 업데이트 확인에 실패합니다. | 인터넷 연결과 업데이트 서버 응답 | 네트워크 연결을 확인한 뒤 다시 실행합니다. | | + | | 업데이트 확인에 실패합니다. | 인터넷 연결과 업데이트 서버 응답 | 네트워크 연결을 확인한 뒤 다시 실행해주시기 바랍니다. | |
| ===== 관련 문서 ===== | ===== 관련 문서 ===== | ||
| 줄 384: | 줄 386: | ||
| * [[products: | * [[products: | ||
| * [[products: | * [[products: | ||
| + | * [[products: | ||
| * [[products: | * [[products: | ||
| - | [[products: | + | [[products: |
products/mpino_studio2/menus_settings.1789108350.txt.gz · 마지막으로 수정됨: 저자 127.0.0.1
